Welcome, Guest. Please login or register.

Author Topic: Help to install C1581 driver  (Read 621 times)

Description:

0 Members and 1 Guest are viewing this topic.

Offline JohnFanteTopic starter

  • Full Member
  • ***
  • Join Date: Aug 2004
  • Posts: 162
    • Show only replies by JohnFante
Help to install C1581 driver
« on: July 03, 2022, 09:51:49 AM »
I have recently bought a C1581 drive (a clone :-)) for my C128.

I am trying to use this program to write d81 images on my A600 running 3.1.4. http://aminet.net/package/misc/emu/c1581

However I can not seem to understand how it is installed/how to use  :-[ (It has been some time since I dabbled in AmigaOS so I am a bit rusty - to say the least).

The instructions say:

"Mounting on trackdisk.device unit 0 write:
mount c0

If you copy c1581-handler to L:, change the mount file accordingly. If you have a 1581 disk in the drive, this will log in the disk and it will appear on the workbench. If you didn't have a disk in the drive, you can now insert one.

This "mount c0" must be done in the directory containing the handler (if you didn't move it to L:) so that it can be located by DOS.

The c1581 handler handles the MFM decoding and encoding itself, thus mfm.device is not used. Mountfiles C0 (unit 0), C1 (unit 1) and C2 (unit 2) are provided. These are for WB2.1+, but it should be easy to add "C0:" and "#" when adding to mountlist."

I have moved c1581-handler to L and rebooted. If I write "mount c0" I get an object unknown error.

If I try to write a disk with the "1581 1 floppyname.d81 - write" I get an "Could not open trackdisk unit 1"

The - rather scetchy - instructions are talking about a mountlist. I am a bit clueless there :-)

Thank you in advance!
Booooiiiing!!!!
 

Online nbache

Re: Help to install C1581 driver
« Reply #1 on: July 03, 2022, 12:08:59 PM »
I think the mountlist was what we used before OS 2.1, when the mountfiles were introduced as an alternative.

The quote mentions the provided mountfiles C0 etc.

Quote
Mountfiles C0 (unit 0), C1 (unit 1) and C2 (unit 2) are provided. These are for WB2.1+,

This would also be what I'd expect to work under 3.1.4 (although I don't have it). Are they actually provided? If so, they (or one of them, probably C0) should be copied to SYS:Devs/DOSDrivers, the contents of which should automaticaly be mounted (activated) at boot time.

Best regards,

Niels
 

Offline JohnFanteTopic starter

  • Full Member
  • ***
  • Join Date: Aug 2004
  • Posts: 162
    • Show only replies by JohnFante
Re: Help to install C1581 driver
« Reply #2 on: July 03, 2022, 07:04:08 PM »
Hi Niels

Copying the mountfiles to SYS:Devs/DOSDrivers followed by a reboot did the trick.

Thank you very much   ;D

Booooiiiing!!!!
 

Offline TjLaZer

  • Hero Member
  • *****
  • Join Date: Aug 2002
  • Posts: 3244
    • Show only replies by TjLaZer
    • http://www.vintagecomputercafe.com/amiga.htm
Re: Help to install C1581 driver
« Reply #3 on: September 14, 2022, 09:31:19 PM »
You can’t write 1581 disk images.  It just mounts the disk and you can copy files to the disks.  You have to format the disk on the commodore first, then you can mount the disk and copy files to it.  A warning though as it seems this driver is really buggy.  If you copy a file you can’t rename the file as it hangs and you need to reboot and start again.
Going Bananas over AMIGAs since 1987...

Looking for Fusion Fourty PNG ROMs V3.4?

:flame: :banana: :banana: :banana: