Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: Ninja Mission title screen music  (Read 821 times)

0 Members and 1 Guest are viewing this topic.

Offline TjLaZer

Ninja Mission title screen music
« on: February 28, 2021, 06:54:57 PM »
Long time fan of this classic.  Use to play it all the time on my Amiga and C-64 back in the day!  All these years I always thought the title music was odd, well after trying the game on my Atari ST I can see why.  Seems the music is missing some channels! The ST version plays the music great, but I can tell some channels play the same thing on the Amiga, that's why it sound weird.  Seems that all copied of the game do this on the Amiga!  Even the WHDload versions I tried from original disks.  WTH.  Wonder if anyone can fix this?   LOL

Amiga version playing music on title screen (sounds like some channels are missing):
https://www.youtube.com/watch?v=qonkrMFkoKI&ab_channel=MorganKell

ST version playing music on title screen:
https://www.youtube.com/watch?v=MBfz1MpvE3c&ab_channel=1CreditGaming
« Last Edit: February 28, 2021, 07:28:13 PM by TjLaZer »
Going Bananas over AMIGAs since 1987...

Looking for Fusion Fourty PNG ROMs V3.4?

:flame: :banana: :banana: :banana:
 

Offline Matt_H

Re: Ninja Mission title screen music
« Reply #1 on: March 03, 2021, 03:49:06 AM »
So I guess the question to figure out is whether it's a problem with the playback code or a problem with the underlying composition. I was going to suggest checking Exotica for a raw .mod file, but it seems it's a .cust, presumably meaning playback and composition are inextricably integrated. I think the odds are long, but maybe EaglePlayer or similar can tease out the "correct" sounds? Otherwise this is probably a task for the WHDLoad guys to figure out. :)