Amiga.org

Amiga.org specific forums => New User Introductions => Topic started by: JimP on August 29, 2018, 02:28:36 PM

Title: Hello out there !
Post by: JimP on August 29, 2018, 02:28:36 PM
I was JimP on the I-Amiga Bitnet list back in 1988. Tried to sign up for it again, via web page, only got the auto-reply, nothing from the mail list owner.

I had an A1000 back then, still do, and it worked last time I booted it up. Over the the years back then I bought Fred Fish pd/shareware disks. I have a CBM 1084 RGB monitor, it worked last time I used it as well.

Bought three A500s, I don't think any work. Nor does my external floppy drive.

My last Amiga purchase was a used A3000. It worked last time I booted it up. Has a 52 meg and a 105 meg SCSI hdds in it. Software I purchased for it was Final Copy, Directory Opus, and the Amiga version of Lotus 1-2-3.

I hope to get at least one of the A500s working.
Title: Re: Hello out there !
Post by: graffias79 on August 29, 2018, 04:02:58 PM
Welcome!  The A3000 is a beautiful machine!  I seriously regret selling mine years ago.  I now have an A500, A1200, and A4000 whose motherboard is out for repairs.
Title: Re: Hello out there !
Post by: F1Lupo on August 29, 2018, 04:11:43 PM
welcome back Jim  :) awesome to still have your A1000 & A3000 working..I still have my A1000, A1200, A4000 running along nicely with my AmigaOne X1000 and as always it's a joy to see amigans worldwide still using their Amigas !
Title: Re: Hello out there !
Post by: eliyahu on August 29, 2018, 04:59:39 PM
welcome to amiga.org, jim!  :)

-- eliyahu
Title: Re: Hello out there !
Post by: JimP on September 02, 2018, 09:29:52 PM
Thank you all !