Welcome, Guest. Please login or register.

Author Topic: AfA_OS 4.7 installation problem patching RAWBinfo  (Read 2098 times)

Description:

0 Members and 1 Guest are viewing this topic.

Offline LoadWBTopic starter

  • Hero Member
  • *****
  • Join Date: Jul 2006
  • Posts: 2901
  • Country: 00
    • Show only replies by LoadWB
AfA_OS 4.7 installation problem patching RAWBinfo
« on: April 22, 2010, 04:24:27 AM »
I have RAWBInfo in SYS:WBStartup.  The rawbinfo_patch program completes successfully, but here are my results:

Code: [Select]
12.Hawking:WBStartup> list RAWB#?
RAWBinfo_new                     50720 ----rwed Today     23:13:07
RAWBinfo_new.info                 7530 ----rwed Today     23:13:07
rawbinfo                         50720 ----rwed 30-Mar-01 15:23:36
rawbinfo.info                     7530 ----rw-d Today     23:19:09
4 files - 120 blocks used

12.Hawking:WBStartup> version full file rawbinfo
RAWBInfo 1.28 (03/30/2001)
Written by Stephan Rupprecht

12.Hawking:WBStartup> version full file rawbinfo_new
RAWBInfo 1.28 (03/30/2001)
Written by Stephan Rupprecht


Notice same version, same file sizes.  Docs say it should report v1.35 and a size of 53744.  Anybody have any ideas?

(In reference to my questions about compatibility with other utilities, following the installation documentation clearly references disabling PowerIcons and IconBeFast.)
 

Offline LoadWBTopic starter

  • Hero Member
  • *****
  • Join Date: Jul 2006
  • Posts: 2901
  • Country: 00
    • Show only replies by LoadWB
Re: AfA_OS 4.7 installation problem patching RAWBinfo
« Reply #1 on: April 23, 2010, 03:33:43 AM »
Okay, I took the plunge and cold-booted the system.  After crashing a few times on boot-up because I did not remember PowerIcons was in my u-s, I have a working installation of AfA OS.  Apprently the patch really was sucessful as 32-bit icons work in RAWBinfo, even though the version does not seem to jive with the docs.

Now a question comes to mind: what and where is RAWBinfo v1.35?

Additionally, I am apparently having difficulties selecting skins.  I will play with that a little more.

Lastly, in regards to the installer.  It installed the afa_prefs and ttf_manager programs but not the icons.  I copied them over manually and un-snapshotted them.  All looks well, and I am very happy with the icon system (yeah, form-over-function wins my heart in this regard!)

Thanks for all your hard work, Bernd!
 

Offline mfilos

  • Hero Member
  • *****
  • Join Date: Aug 2005
  • Posts: 662
    • Show only replies by mfilos
    • http://mfilos.blogspot.com/
Re: AfA_OS 4.7 installation problem patching RAWBinfo
« Reply #2 on: April 23, 2010, 06:02:14 AM »
If you want I can send you my own v1.35 Rawbinfo mate.
Visit my Amiga blog here
- A600: Vampire V3, 128MB, A604n, 16GB CF, Indivision ECS, RapidRoad, MAS-Player + Custom Audio Mixer (internal), HxC SD + Slim floppy (internal)
 

Offline LoadWBTopic starter

  • Hero Member
  • *****
  • Join Date: Jul 2006
  • Posts: 2901
  • Country: 00
    • Show only replies by LoadWB
Re: AfA_OS 4.7 installation problem patching RAWBinfo
« Reply #3 on: April 23, 2010, 06:13:16 AM »
Thanks, PM sent.

I found reference to 1.35 at the Unofficial Boing Bag 3 listing, but not at Stephen Ruprecht's website, which shows 1.18b.  This is also listed as the latest version at BB3, whereas 3.9 is shown to contain 1.35.  Right over my head.  I have BB2 installed, so this is interesting.  I will check my 1200 and 2000 installations to see what version they have as well.
 

Offline LoadWBTopic starter

  • Hero Member
  • *****
  • Join Date: Jul 2006
  • Posts: 2901
  • Country: 00
    • Show only replies by LoadWB
Re: AfA_OS 4.7 installation problem patching RAWBinfo
« Reply #4 on: April 23, 2010, 08:31:37 AM »
The compulsion against boredom often leads to doing things the long or hard way, or sometimes both.  Rather than boot up my 1200 or 2000, I decided to take a look at the mysterious Boing Bag 2 update and the AmigaOS-Update.  7-Zip opens the file easily, and even opens the Update file, but extraction requires a password.

A quick Yahoo! search turns up that it is indeed password-protected, though it can be found using myriad password recovery tools.  Also mentioned is that the updater has a look at a few files on the 3.9 CD to dig up a password.  This lead me to do some extremely rudimentary sleuthing.

A couple of passes of free recovery tools turned up nothing (trials are limited.)  I looked at the Installer to see the reference to c/Updater.  I dumped c/Updater to a hex editor to see the references to the media files, but also a syntax help.

Executing c/Updater ? returns two arguments: updatefile/a targetdir/a.  So me brain turns just a little bit, puts my original 3.9 CD in the drive (yes, I did that with my brain,) and works up this command

Code: [Select]
c/Updater RAM:BoingBag3.9-2/AmigaOS-Update RAM:BB2

And voila.  A dump of the Boing Bag 2 AmigaOS-Update file, including the elusive RAWBinfo v1.35.

Scout reports my system at BB2, but obviously something screwy has happened along the way.  Maybe as a result of having the same installation move with me all the way from 1.3 through 2.04, 3.1, 3.5, and now landing on 3.9.  *sigh*  Anyway, makes me wonder how many other files are not up to BB2 level.

Sometime when the groove strikes me I will work up a quick check against the BB2 extract and my existing files to look for differences in versions.
 

Offline pixie

  • Sr. Member
  • ****
  • Join Date: Apr 2002
  • Posts: 480
    • Show only replies by pixie
    • http://savoc.tripod.com
Re: AfA_OS 4.7 installation problem patching RAWBinfo
« Reply #5 on: April 09, 2023, 10:13:20 AM »
Try as I might I cannot get this library to patch, the one I get in bb3 has the size but is 1.36, and on aminet is 1.18. Does anyone have it or the patched one?


pixie- writing from a paradise called Portugal