Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: Will Amiga OS 3.2 require a diff kickstart to 3.1.4?  (Read 1653 times)

0 Members and 1 Guest are viewing this topic.

Offline AndyFC

Will Amiga OS 3.2 require a diff kickstart to 3.1.4?
« on: February 20, 2021, 04:43:28 PM »
Hi all,

The title says it all really. The reason I'm asking is I'd like to upgrade to the latest version of Amiga OS but wonder weather to hold off until 3.2 is released. Alternatively is anyone aware if there will be discounts for those who already have 3.1.4?

Thank you.
A1200 in DIY Tower. 3.0 ROMS (but 3.1 in RAM), 3.5" HD, CD Rom and IDE to SD adapter running off the internal IDE port (using the A4000 4-port IDE adapter from Amigakit), Blizzard 1230-IV, with 32MB 60ns RAM and 50MHz 68882 FPU. 3COM PCMCIA Network card running with Miami DX. https://www.youtube.com/watch?v=1PrGdL6XjmE
 

Offline Pat the Cat

Re: Will Amiga OS 3.2 require a diff kickstart to 3.1.4?
« Reply #1 on: February 20, 2021, 05:05:30 PM »
I think the devs (God Bless 'Em All) are still working out what's needed, what's desirable, and what works in terms of all the "issues".

"Almost certainly" based on past releases but that is just my opinion and means next to nothing in this case.

I feel pretty certain there aren't that many issues, that is just my feeling.

Perhaps the devs want more people to report issues to check first. That's just a possibility (but it would help make a better release).

Even if they have identified specific issues, that doesn't mean they have tested, solid solutions for them yet.i

I have no idea whatsoever of what any specific issue is.
« Last Edit: February 20, 2021, 05:12:18 PM by Pat the Cat »
"To recurse is human. To iterate, divine."

A1200, Vanilla, Surf Squirrel, SD Card, KS 3.0/3.z, PCMCIA dev
A500, Vanilla, A570, Rev 5, KS 1.2/1.3 Testbench system
Rasp Pi, UAE4ARM, 3D laser scanner, experimental, hoping for AmigaOS4Arm, based on Watterott Fabscan Pi
 

Offline NinjaCyborg

Re: Will Amiga OS 3.2 require a diff kickstart to 3.1.4?
« Reply #2 on: February 20, 2021, 07:03:25 PM »
At this point you may as well wait. Hopefully it's not too far off, sometime this H1 apparently.
 

Offline Gulliver

Re: Will Amiga OS 3.2 require a diff kickstart to 3.1.4?
« Reply #3 on: February 20, 2021, 10:07:39 PM »
Hi all,

The title says it all really. The reason I'm asking is I'd like to upgrade to the latest version of Amiga OS but wonder weather to hold off until 3.2 is released. Alternatively is anyone aware if there will be discounts for those who already have 3.1.4?

Thank you.

Requirements:

1) Kickstart ROM 3.1, 3.1.4 or 3.2.

2) At least 2MB of total RAM available.
   Soft-loading updated OS modules combined with larger hard disk
   media and additional software customizations may require additional
   memory above the 2 MB mentioned. The physical 3.2 ROM will help
   reduce the memory footprint of hard disk loaded modules over an
   older ROM beyond other benefits.

3) A hard drive with a minimum of 10 MB of free space.

Questions regarding sales, distribution and discounts should be directly addressed by Hyperion. We do not manage that.

Offline Pat the Cat

Re: Will Amiga OS 3.2 require a diff kickstart to 3.1.4?
« Reply #4 on: February 20, 2021, 11:05:24 PM »
OK... Judging from that, the means to acquire the full upgrade can be done with software alone if you have lots of memory... but for best effect, get the Kickstart especially if you don't have lotsa ram.

What's this upgradable intuition.library? That intrigues me.

Anyway, I feel kind of compelled just do a purchase. The Amiga has given me a lot., Ocassionally earning a living from it.  I've tried to help other users as part of that.

Time to put some money Hyperion's way. I don't need it really... but I would feel better if I personaly supported the effort already put in to the current release.

Next payday, I'm not exactly rolling in moolah.
"To recurse is human. To iterate, divine."

A1200, Vanilla, Surf Squirrel, SD Card, KS 3.0/3.z, PCMCIA dev
A500, Vanilla, A570, Rev 5, KS 1.2/1.3 Testbench system
Rasp Pi, UAE4ARM, 3D laser scanner, experimental, hoping for AmigaOS4Arm, based on Watterott Fabscan Pi
 

Offline NinjaCyborg

Re: Will Amiga OS 3.2 require a diff kickstart to 3.1.4?
« Reply #5 on: February 21, 2021, 11:29:53 AM »
the upgradable intuition library has the ability to move windows partially off screen. It's not compatible with cybergfx rtg (but is with p96) so it's not the default, so as not to break anyone that can't boot because of that. But you can use rom building tools e.g. Remus to make your own soft kickstart image that swaps it out for the improved one.
 

Offline kolla

Re: Will Amiga OS 3.2 require a diff kickstart to 3.1.4?
« Reply #6 on: February 21, 2021, 02:48:46 PM »
With 3.2 being able to bootstrap from 3.1, I would prefer (and recommend) using OS 3.1 kickstart over using 3.1.4 kickstart, and simply use a dedicated “old” FFS bootstrap partition for LoadModule and rom modules. This way retains max compatibility with older software, avoid certain buggy shell, booting from floppy (wb and icon lib) etc.
« Last Edit: February 21, 2021, 03:35:13 PM by kolla »
B5D6A1D019D5D45BCC56F4782AC220D8B3E2A6CC
---
A3000/060CSPPC+CVPPC/128MB + 256MB BigRAM/Deneb USB
A4000/CS060/Mediator4000Di/Voodoo5/128MB
A1200/Blz1260/IndyAGA/192MB
A1200/Blz1260/64MB
A1200/Blz1230III/32MB
A1200/ACA1221
A600/V600v2/Subway USB
A600/Apollo630/32MB
A600/A6095
CD32/SX32/32MB/Plipbox
CD32/TF328
A500/V500v2
A500/MTec520
CDTV
MiSTer, MiST, FleaFPGAs and original Minimig
Peg1, SAM440 and Mac minis with MorphOS
 

Offline NinjaCyborg

Re: Will Amiga OS 3.2 require a diff kickstart to 3.1.4?
« Reply #7 on: February 21, 2021, 03:15:56 PM »
In your case, it's best you stick with 1.3.
 

Offline TribbleSmasher

Re: Will Amiga OS 3.2 require a diff kickstart to 3.1.4?
« Reply #8 on: February 21, 2021, 03:35:58 PM »
I'm glad they aim for the more equipped machines instead of trying to support 1meg 68000 ones. There is really no need for a base A600 to get the latest updates just for playing disk games.

And a lot of A500s can cope with 1.3 for another 25 years, for sure.😊
 

Offline kolla

Re: Will Amiga OS 3.2 require a diff kickstart to 3.1.4?
« Reply #9 on: February 21, 2021, 03:38:48 PM »
In your case, it's best you stick with 1.3.
Why?
B5D6A1D019D5D45BCC56F4782AC220D8B3E2A6CC
---
A3000/060CSPPC+CVPPC/128MB + 256MB BigRAM/Deneb USB
A4000/CS060/Mediator4000Di/Voodoo5/128MB
A1200/Blz1260/IndyAGA/192MB
A1200/Blz1260/64MB
A1200/Blz1230III/32MB
A1200/ACA1221
A600/V600v2/Subway USB
A600/Apollo630/32MB
A600/A6095
CD32/SX32/32MB/Plipbox
CD32/TF328
A500/V500v2
A500/MTec520
CDTV
MiSTer, MiST, FleaFPGAs and original Minimig
Peg1, SAM440 and Mac minis with MorphOS
 

Offline duga

Re: Will Amiga OS 3.2 require a diff kickstart to 3.1.4?
« Reply #10 on: February 21, 2021, 06:11:30 PM »
I'm glad they aim for the more equipped machines instead of trying to support 1meg 68000 ones. There is really no need for a base A600 to get the latest updates just for playing disk games.

And a lot of A500s can cope with 1.3 for another 25 years, for sure.😊

2 MB is required/recommended for 3.1.4 too.
 

Offline TribbleSmasher

Re: Will Amiga OS 3.2 require a diff kickstart to 3.1.4?
« Reply #11 on: March 06, 2021, 12:39:38 PM »
Slightly offtopic, but interesting nonetheless:
Quote
Current Hardware Requirements for AmigaOS 3.2:

1) An Amiga model 1000, 500, 2000, 600, 1200, 3000, 3000T, 4000D or 4000T, and minor variants of those.

2) Kickstart ROM 3.1, 3.1.4 or 3.2.

3) At least 2MB of total RAM available.
Soft-loading updated OS modules combined with larger hard disk
media and additional software customizations may require additional
memory above the 2 MB mentioned. The physical 3.2 ROM will help
reduce the memory footprint of hard disk loaded modules over an
older ROM beyond other benefits.

4) A hard drive with a minimum of 10 MB of free space.

5) If you don't have AmigaOS 3.1 or better already installed, you
will require a physical copy of the "Install3.2" floppy disk. If in
addition to that, you are still using the old 3.1 Kickstart ROM
you will also require a physical copy of the "Modules" disk that
matches your hardware (All floppies should be available as ADF
images in a directory of the retail CD-ROM).

6) A CD-ROM drive unit accessible to your Amiga, or the contents of
the AmigaOS 3.2 CD-ROM copied on to an Amiga compatible storage
media

Note: AmigaOS 3.2 has been tested to work under many emulated/FPGA systems.
Gulliver @ EAB
http://eab.abime.net/showpost.php?p=1467878&postcount=1048

Offline AndyFC

Re: Will Amiga OS 3.2 require a diff kickstart to 3.1.4?
« Reply #12 on: March 07, 2021, 09:59:57 AM »
Thank you. I think I'll wait until 3.2 is out and get it otherwise I'll be getting 3.1.4 and then have to apply patches and updates which I'm aiming to move away from. My hardware Kickstart is 3.0 so I fall below minimum requirements anyway and need to upgrade.
A1200 in DIY Tower. 3.0 ROMS (but 3.1 in RAM), 3.5" HD, CD Rom and IDE to SD adapter running off the internal IDE port (using the A4000 4-port IDE adapter from Amigakit), Blizzard 1230-IV, with 32MB 60ns RAM and 50MHz 68882 FPU. 3COM PCMCIA Network card running with Miami DX. https://www.youtube.com/watch?v=1PrGdL6XjmE
 

Offline kolla

Re: Will Amiga OS 3.2 require a diff kickstart to 3.1.4?
« Reply #13 on: March 08, 2021, 02:34:59 AM »
If you can softkick 3.1 you can also softkick 3.2. You may wish to have a minimalist “legacy” FFS partition that holds the softkicker and kickstart (and bootctrl to disable this bootstrap partition from next reset onwards, so that the 3.2 partition becomes default boot filesystem.)
B5D6A1D019D5D45BCC56F4782AC220D8B3E2A6CC
---
A3000/060CSPPC+CVPPC/128MB + 256MB BigRAM/Deneb USB
A4000/CS060/Mediator4000Di/Voodoo5/128MB
A1200/Blz1260/IndyAGA/192MB
A1200/Blz1260/64MB
A1200/Blz1230III/32MB
A1200/ACA1221
A600/V600v2/Subway USB
A600/Apollo630/32MB
A600/A6095
CD32/SX32/32MB/Plipbox
CD32/TF328
A500/V500v2
A500/MTec520
CDTV
MiSTer, MiST, FleaFPGAs and original Minimig
Peg1, SAM440 and Mac minis with MorphOS
 

Offline Steady

Re: Will Amiga OS 3.2 require a diff kickstart to 3.1.4?
« Reply #14 on: March 10, 2021, 02:40:35 AM »
If you want to minimise the number of modules that need loading into RAM then waiting for 3.2 and getting that ROM when it is all available is the best option.