Welcome, Guest. Please login or register.

Author Topic: Problems with Amibian  (Read 4781 times)


0 Members and 1 Guest are viewing this topic.

Offline AmigaBrunoTopic starter

  • Sr. Member
  • ****
  • Join Date: Nov 2012
  • Posts: 408
    • Show only replies by AmigaBruno
Problems with Amibian
« on: January 22, 2019, 10:11:43 PM »
I've been using Amibian for about 2 days now as an A1200 with Workbench 3.1 and a 4Gb expansion. I've managed to install a classic "Workbench Lite" HDF file, which is by Bloodwych of EAB Abime, but as I don't understand all the enhancements to the Workbench 3.1 that he's installed, there are some problems. One problem was trying to install some ADF image files of the game "Civilization" onto the Bloodwych "Workbench Lite" HDF. On my first attempt, it was really hard to read the installation instructions because the window had a rainbow coloured background. Even so, I managed to install it to hard drive, but then when I started to try and play the game it kept asking me to insert floppy disks! After this, I managed to set the Workbench background and all Window backgrounds to plain black, so I could read the installation instructions clearly. Unfortunately, when the installer opened a window it still had the rainbow background! After this, I decided to start from scratch by making my own HDF and installing Workbench 3.1. I thought I should make the size 2Gb. I found that there was no way I could detect or format it! Next, I decided to create a much smaller HDF, meaning the kind of size A1200 owners may have had in the early to mid 1990s. I set the size as 250Mb. I immediately saw that an icon saying DH0:NDOS appeared on the screen! Next, I used the software on the Install disk to try and format my new 250Mb hard drive, but it couldn't do it. I ended up just selecting the DH0:NDOS icon and selecting Format from the Workbench pull down menu. I found this worked! Following this, I managed to install Workbench 3.1 onto DH0:. Finally, I was ready to try installing "Civilization" again. I was able to read all the installation instructions on the orginal light grey Workbench 3.1 background. Then after all the work I'd been through installing it, I started to play the game and it asked me to insert a floppy disk! Not only that, but it asked for disk 8, but there were only 4 disks in the set! Obviously, I'll have to download a different version of "Civilization" and try again. I was using "Civilization" V855.01 German language version, which comes on four ADF files.

Apart from the above, I've been having some problems with the picture not fitting on my TV screen. I'm using a MATSUI HD TV which is several years old and the Raspberry Pi is connected via HDMI cable. This TV works fine with a real Amiga A1200 and even allows me to stretch the Amiga video output to 16:9 mode. I immediately found that the Amibian picture was forced into 4.3 mode, but adjusting the TV display with my remote control didn't affect it. The top and bottom of the picture were off the screen. I tried adjusting this in Amibian under Display, but although selecting Fullscreen causes the Workench display to change to 16.9 mode, filling up my TV screen, the leftmost part of the screen is off the edge of the screen. This means that the W in Workbench isn't shown. The top and bottom of the screen are still not shown on the TV unless I drag the Workbench screen down.

I hope someone can tell me how to solve these problems!


Offline paul1981

Re: Problems with Amibian
« Reply #1 on: January 23, 2019, 07:28:37 PM »
If you've installed Workbench to hard disk correctly via the Installer diskette then you should have a 'Prefs' drawer on your boot partition (normally DH0). Inside there are programs to personalise your Workbench. One such program is called Overscan ; you can move the screen location around with that and also stretch it out to perfectly fill your display. If you're happy with the changes you should click the Save button. If your Workbench is installed correctly, then the next time you boot it will remember the screen location.

Offline NinjaCyborg

Re: Problems with Amibian
« Reply #2 on: January 23, 2019, 09:52:16 PM »
Why use a random custom workbench HDF file? Why not make your own from a clean install, then you won't have any of these problems.