Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: Icaros in VirtualBox networking  (Read 2218 times)

0 Members and 1 Guest are viewing this topic.

Offline motorollin

Icaros in VirtualBox networking
« on: February 27, 2010, 01:33:59 PM »
I've just downloaded Icaros Desktop VE 1.2 and imported the appliance into VirtualBox. It boots fine, but I can't get networking to work. I've set the virtual NIC to the PCNet II and configured it to bridge to my Airport card. In AROS, the VM picks up a 192.168.0.x IP address with a 192.168.2.x gateway and DNS address, but I can't ping either of these addresses, or my router, or anything on the Internet. I've also tried setting the virtual NIC to NAT with the same effect. Any ideas?

--
moto
Code: [Select]
10  IT\'S THE FINAL COUNTDOWN
20  FOR C = 1 TO 2
30     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NAAAA
40     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NA-NA-NAAAAA
50  NEXT C
60  NA-NA-NAAAA
70  NA-NA NA-NA-NA-NA-NAAAA NAAA-NAAAAAAAAAAA
80  GOTO 10
 

Offline paolone

Re: Icaros in VirtualBox networking
« Reply #1 on: February 27, 2010, 02:08:30 PM »
Quote from: motorollin;545364
the VM picks up a 192.168.0.x IP address with a 192.168.2.x gateway

Don't you think there's something wrong here? ;-)

Either your gateway setting or your IP address is wrong.
p.bes

 

Offline motorollin

Re: Icaros in VirtualBox networking
« Reply #2 on: February 27, 2010, 02:37:36 PM »
I did think it was strange that the IP and gateway addresses were in different ranges, but presumably these are the addresses allocated by VirtualBox's DHCP server. I don't understand why it would allocate addresses which don't work, but I'll try changing them when I get home.

--
moto
Code: [Select]
10  IT\'S THE FINAL COUNTDOWN
20  FOR C = 1 TO 2
30     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NAAAA
40     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NA-NA-NAAAAA
50  NEXT C
60  NA-NA-NAAAA
70  NA-NA NA-NA-NA-NA-NAAAA NAAA-NAAAAAAAAAAA
80  GOTO 10
 

Offline motorollin

Re: Icaros in VirtualBox networking
« Reply #3 on: February 27, 2010, 02:39:18 PM »
dp
« Last Edit: February 27, 2010, 06:40:47 PM by motorollin »
Code: [Select]
10  IT\'S THE FINAL COUNTDOWN
20  FOR C = 1 TO 2
30     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NAAAA
40     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NA-NA-NAAAAA
50  NEXT C
60  NA-NA-NAAAA
70  NA-NA NA-NA-NA-NA-NAAAA NAAA-NAAAAAAAAAAA
80  GOTO 10
 

Offline LoadWB

Re: Icaros in VirtualBox networking
« Reply #4 on: February 27, 2010, 05:37:59 PM »
At least you got it to boot for you :-P  What is your host system configuration?
 

Offline motorollin

Re: Icaros in VirtualBox networking
« Reply #5 on: February 27, 2010, 05:50:56 PM »
Quote from: LoadWB;545399
At least you got it to boot for you :-P

Actually I had a lot of problems getting it to boot when I tried to configure a VM manually and install from the ISO. When I downloaded the VMWare version and imported it into VirtualBox it booted first time.

Quote from: LoadWB;545399
What is your host system configuration?

Here's the VirtualBox config file:
Code: [Select]
<?xml version=&quot;1.0&quot;?>
<VirtualBox xmlns=&quot;http://www.innotek.de/VirtualBox-settings&quot; version=&quot;1.9-macosx&quot;>
  <Machine uuid=&quot;{54776d4d-30bb-40c7-8af2-b34f3f8f6f71}&quot; name=&quot;Icaros Desktop VE 1.2&quot; OSType=&quot;Other&quot; lastStateChange=&quot;2010-02-27T17:44:35Z&quot;>
    <Description>A pre-configured AROS desktop environment</Description>
    <ExtraData>
      <ExtraDataItem name=&quot;GUI/AutoresizeGuest&quot; value=&quot;on&quot;/>
      <ExtraDataItem name=&quot;GUI/Fullscreen&quot; value=&quot;off&quot;/>
      <ExtraDataItem name=&quot;GUI/LastCloseAction&quot; value=&quot;powerOff&quot;/>
      <ExtraDataItem name=&quot;GUI/LastWindowPostion&quot; value=&quot;112,44,1024,752&quot;/>
      <ExtraDataItem name=&quot;GUI/MiniToolBarAlignment&quot; value=&quot;bottom&quot;/>
      <ExtraDataItem name=&quot;GUI/MiniToolBarAutoHide&quot; value=&quot;on&quot;/>
      <ExtraDataItem name=&quot;GUI/SaveMountedAtRuntime&quot; value=&quot;yes&quot;/>
      <ExtraDataItem name=&quot;GUI/Seamless&quot; value=&quot;off&quot;/>
      <ExtraDataItem name=&quot;GUI/ShowMiniToolBar&quot; value=&quot;yes&quot;/>
    </ExtraData>
    <Hardware version=&quot;2&quot;>
      <CPU count=&quot;1&quot;>
        <HardwareVirtEx enabled=&quot;true&quot; exclusive=&quot;false&quot;/>
        <HardwareVirtExNestedPaging enabled=&quot;true&quot;/>
        <HardwareVirtExVPID enabled=&quot;true&quot;/>
        <PAE enabled=&quot;true&quot;/>
      </CPU>
      <Memory RAMSize=&quot;256&quot;/>
      <Boot>
        <Order position=&quot;1&quot; device=&quot;Floppy&quot;/>
        <Order position=&quot;2&quot; device=&quot;DVD&quot;/>
        <Order position=&quot;3&quot; device=&quot;HardDisk&quot;/>
        <Order position=&quot;4&quot; device=&quot;None&quot;/>
      </Boot>
      <Display VRAMSize=&quot;4&quot; monitorCount=&quot;1&quot; accelerate3D=&quot;false&quot; accelerate2DVideo=&quot;false&quot;/>
      <RemoteDisplay enabled=&quot;false&quot; port=&quot;3389&quot; authType=&quot;Null&quot; authTimeout=&quot;5000&quot;/>
      <BIOS>
        <ACPI enabled=&quot;true&quot;/>
        <IOAPIC enabled=&quot;false&quot;/>
        <Logo fadeIn=&quot;true&quot; fadeOut=&quot;true&quot; displayTime=&quot;0&quot;/>
        <BootMenu mode=&quot;MessageAndMenu&quot;/>
        <TimeOffset value=&quot;0&quot;/>
        <PXEDebug enabled=&quot;false&quot;/>
      </BIOS>
      <USBController enabled=&quot;true&quot; enabledEhci=&quot;false&quot;/>
      <Network>
        <Adapter slot=&quot;0&quot; enabled=&quot;true&quot; MACAddress=&quot;08002732FCC9&quot; cable=&quot;true&quot; speed=&quot;0&quot; type=&quot;Am79C970A&quot;>
          <BridgedInterface name=&quot;en1: AirPort&quot;/>
        </Adapter>
        <Adapter slot=&quot;1&quot; enabled=&quot;false&quot; MACAddress=&quot;0800273EE808&quot; cable=&quot;true&quot; speed=&quot;0&quot; type=&quot;Am79C973&quot;/>
        <Adapter slot=&quot;2&quot; enabled=&quot;false&quot; MACAddress=&quot;080027E1D98A&quot; cable=&quot;true&quot; speed=&quot;0&quot; type=&quot;Am79C973&quot;/>
        <Adapter slot=&quot;3&quot; enabled=&quot;false&quot; MACAddress=&quot;080027F5D0BD&quot; cable=&quot;true&quot; speed=&quot;0&quot; type=&quot;Am79C973&quot;/>
        <Adapter slot=&quot;4&quot; enabled=&quot;false&quot; MACAddress=&quot;0800277E2964&quot; cable=&quot;true&quot; speed=&quot;0&quot; type=&quot;Am79C973&quot;/>
        <Adapter slot=&quot;5&quot; enabled=&quot;false&quot; MACAddress=&quot;080027D9AC0B&quot; cable=&quot;true&quot; speed=&quot;0&quot; type=&quot;Am79C973&quot;/>
        <Adapter slot=&quot;6&quot; enabled=&quot;false&quot; MACAddress=&quot;080027B918E2&quot; cable=&quot;true&quot; speed=&quot;0&quot; type=&quot;Am79C973&quot;/>
        <Adapter slot=&quot;7&quot; enabled=&quot;false&quot; MACAddress=&quot;080027FBCE62&quot; cable=&quot;true&quot; speed=&quot;0&quot; type=&quot;Am79C973&quot;/>
      </Network>
      <UART>
        <Port slot=&quot;0&quot; enabled=&quot;false&quot; IOBase=&quot;0x3f8&quot; IRQ=&quot;4&quot; hostMode=&quot;Disconnected&quot;/>
        <Port slot=&quot;1&quot; enabled=&quot;false&quot; IOBase=&quot;0x3f8&quot; IRQ=&quot;4&quot; hostMode=&quot;Disconnected&quot;/>
      </UART>
      <LPT>
        <Port slot=&quot;0&quot; enabled=&quot;false&quot; IOBase=&quot;0x378&quot; IRQ=&quot;4&quot;/>
        <Port slot=&quot;1&quot; enabled=&quot;false&quot; IOBase=&quot;0x378&quot; IRQ=&quot;4&quot;/>
      </LPT>
      <AudioAdapter controller=&quot;AC97&quot; driver=&quot;CoreAudio&quot; enabled=&quot;true&quot;/>
      <SharedFolders/>
      <Clipboard mode=&quot;Bidirectional&quot;/>
      <Guest memoryBalloonSize=&quot;0&quot; statisticsUpdateInterval=&quot;0&quot;/>
      <GuestProperties>
        <GuestProperty name=&quot;/VirtualBox/HostInfo/GUI/LanguageID&quot; value=&quot;en_US&quot; timestamp=&quot;1267286068778361000&quot; flags=&quot;&quot;/>
      </GuestProperties>
    </Hardware>
    <StorageControllers>
      <StorageController name=&quot;IDE Controller&quot; type=&quot;PIIX4&quot; PortCount=&quot;2&quot;>
        <AttachedDevice passthrough=&quot;false&quot; type=&quot;DVD&quot; port=&quot;1&quot; device=&quot;0&quot;/>
        <AttachedDevice type=&quot;HardDisk&quot; port=&quot;0&quot; device=&quot;0&quot;>
          <Image uuid=&quot;{e391f8cc-73be-461a-b41b-726f2e5fe1bc}&quot;/>
        </AttachedDevice>
      </StorageController>
      <StorageController name=&quot;Floppy Controller&quot; type=&quot;I82078&quot; PortCount=&quot;1&quot;>
        <AttachedDevice type=&quot;Floppy&quot; port=&quot;0&quot; device=&quot;0&quot;/>
      </StorageController>
    </StorageControllers>
  </Machine>
</VirtualBox>
Code: [Select]
10  IT\'S THE FINAL COUNTDOWN
20  FOR C = 1 TO 2
30     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NAAAA
40     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NA-NA-NAAAAA
50  NEXT C
60  NA-NA-NAAAA
70  NA-NA NA-NA-NA-NA-NAAAA NAAA-NAAAAAAAAAAA
80  GOTO 10
 

Offline motorollin

Re: Icaros in VirtualBox networking
« Reply #6 on: February 27, 2010, 06:35:25 PM »
Ok, sorted and posting this from Icaros in VirtualBox :) I tried various combinations of 192.168.0.x and 192.168.2.x but nothing worked. In the end I installed XP in a new VirtualBox machine and this picked up IP and gateway settings in the 10.0.2.x range. I manually configured Icaros with the same settings and it worked. I have no idea why Icaros obtained different network settings to XP. Is there any issue with DHCP in AROS?

--
moto
Code: [Select]
10  IT\'S THE FINAL COUNTDOWN
20  FOR C = 1 TO 2
30     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NAAAA
40     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NA-NA-NAAAAA
50  NEXT C
60  NA-NA-NAAAA
70  NA-NA NA-NA-NA-NA-NAAAA NAAA-NAAAAAAAAAAA
80  GOTO 10
 

Offline motorollin

Re: Icaros in VirtualBox networking
« Reply #7 on: February 27, 2010, 06:35:56 PM »
dp
« Last Edit: February 27, 2010, 06:40:03 PM by motorollin »
Code: [Select]
10  IT\'S THE FINAL COUNTDOWN
20  FOR C = 1 TO 2
30     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NAAAA
40     DA-NA-NAAAA-NAAAA DA-NA-NA-NA-NA-NA-NAAAAA
50  NEXT C
60  NA-NA-NAAAA
70  NA-NA NA-NA-NA-NA-NAAAA NAAA-NAAAAAAAAAAA
80  GOTO 10