Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: Opening applications makes audio stutter  (Read 2489 times)

0 Members and 1 Guest are viewing this topic.

Offline Heiroglyph

Opening applications makes audio stutter
« on: September 28, 2014, 07:12:23 PM »
For example, I have mplayer playing a streaming radio station. (KNAC.com for those interested)

When I open OWB or even Scribble, CPU useage hits 100% and the audio stutters.

I would have expected the scheduler to be better at handling that case, especially on a 2GHz G5.

Is this well known or do I have something configured strangely?

Edit: This still happens if I give mplayer priority 1, higher than the default 0 that scribble and OWB have.

Thanks,
John
« Last Edit: September 28, 2014, 07:15:05 PM by Heiroglyph »
 

Offline Yasu

Re: Opening applications makes audio stutter
« Reply #1 on: September 28, 2014, 07:42:25 PM »
I have pointed out that problem before. But I can't remember why it hasn't been fixed.

Offline Heiroglyph

Re: Opening applications makes audio stutter
« Reply #2 on: September 28, 2014, 07:53:23 PM »
Quote from: Yasu;774119
I have pointed out that problem before. But I can't remember why it hasn't been fixed.


Well, it's good that it's not just me, but it sucks that it's a known issue.

Did you report it to them directly? I just signed up for the mailing list so that I can report things I find along the way.
 

Offline Yasu

Re: Opening applications makes audio stutter
« Reply #3 on: September 28, 2014, 08:31:17 PM »
You can do that via Ambient menu as well. There is a bug tracker there.

Offline Heiroglyph

Re: Opening applications makes audio stutter
« Reply #4 on: September 28, 2014, 09:28:10 PM »
Quote from: Yasu;774126
You can do that via Ambient menu as well. There is a bug tracker there.


Oh, that's fairly hidden, but good to know.

I'm going to narrow it down a bit more before submitting, mplayer has a lot of tasks running, so the problem could be related to any of them.
 

Offline Yasu

Re: Opening applications makes audio stutter
« Reply #5 on: October 01, 2014, 12:14:32 PM »
I found out that Jukebox doesn't have any stuttering when I start OWB. Jukebox is my favourite MorphOS MP3 player :)

Offline smf

Re: Opening applications makes audio stutter
« Reply #6 on: October 01, 2014, 01:20:06 PM »
I have had stuttering audio for over a decade so it will probably be sorted out any day now.
 

Offline itix

Re: Opening applications makes audio stutter
« Reply #7 on: October 01, 2014, 11:34:21 PM »
Quote from: smf;774321
I have had stuttering audio for over a decade so it will probably be sorted out any day now.

If you have old Pegasos it can stutter when gfx acceleration is used. Known hw bug.

But it can also stutter if playback is done from GUI task. AmiNetRadio or Sid4Amiga don't stutter. No idea how it is done in OWB...

Edit: although I just remember that I got complaint SDL has stuttering audio. It is not stuttering on my Mac (G4) so maybe it could be related to specific audio drivers or even just G5 after all...
« Last Edit: October 01, 2014, 11:38:58 PM by itix »
My Amigas: A500, Mac Mini and PowerBook