Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Hollywood MAL AMIStore App Store A600 Memory

AuthorTopic: NetSurf OS3  (Read 1104 times)

0 Members and 1 Guest are viewing this topic.

Offline chris

Re: NetSurf OS3
« Reply #15 on: May 23, 2020, 10:57:22 AM »
Just downloaded NetSurf-gcc-5120.lha and it works great! On my A600/Vampire with OS 3.9, the icon for secure/unsecure connection show as black/black with some red diagonal line but when I click on it, a popup window appears to tell me whether the Web site is secure or not: Very cool! 8)

Excellent, thanks!  Sounds like the transparency isn't working on the image correctly, although IIRC it's fine on the other buttons and this is set up the same.

Quote
I have some debug output, does it help you?

Code: [Select]
(0.000012) [ERR  netsurf] content/fs_backing_store.c:1623 store_write_block: Write failed -1 of 5430 bytes from 0xa231260 at 0x0 block 8192 errno 1
(22.655645) [ERR  netsurf] content/fs_backing_store.c:1623 store_write_block: Write failed -1 of 416 bytes from 0x889ab7c at 0x0 block 8192 errno 1
(22.703605) [ERR  netsurf] content/fs_backing_store.c:1021 set_store_entry: attempt to overwrite entry with in use data
(23.457020) [ERR  netsurf] content/fs_backing_store.c:1716 store: store entry setting failed
(31.298687) [ERR  netsurf] content/fs_backing_store.c:1623 store_write_block: Write failed -1 of 405 bytes from 0xa496f2c at 0x0 block 16384 errno 2
(31.371701) [ERR  netsurf] content/fs_backing_store.c:1623 store_write_block: Write failed -1 of 364 bytes from 0xa496f2c at 0x0 block 24576 errno 3
(31.425047) [ERR  netsurf] content/fs_backing_store.c:1021 set_store_entry: attempt to overwrite entry with in use data
(31.467286) [ERR  netsurf] content/fs_backing_store.c:1716 store: store entry setting failed
(31.500678) [ERR  netsurf] content/fs_backing_store.c:1021 set_store_entry: attempt to overwrite entry with in use data
(31.545188) [ERR  netsurf] content/fs_backing_store.c:1716 store: store entry setting failed
(41.342820) [ERR  netsurf] content/fs_backing_store.c:1623 store_write_block: Write failed -1 of 476 bytes from 0x893c0b4 at 0x0 block 32768 errno 4
(41.412526) [ERR  netsurf] content/fs_backing_store.c:1623 store_write_block: Write failed -1 of 466 bytes from 0x893c0b4 at 0x0 block 40960 errno 5
(41.481880) [ERR  netsurf] content/fs_backing_store.c:1623 store_write_block: Write failed -1 of 466 bytes from 0x893c0b4 at 0x0 block 49152 errno 6
(41.549878) [ERR  netsurf] content/fs_backing_store.c:1623 store_write_block: Write failed -1 of 466 bytes from 0x893c0b4 at 0x0 block 57344 errno 7
(41.617885) [ERR  netsurf] content/fs_backing_store.c:1623 store_write_block: Write failed -1 of 476 bytes from 0x893c0b4 at 0x0 block 65536 errno 8
(41.686039) [ERR  netsurf] content/fs_backing_store.c:1623 store_write_block: Write failed -1 of 476 bytes from 0x893c0b4 at 0x0 block 73728 errno 9
(41.755249) [ERR  netsurf] content/fs_backing_store.c:1623 store_write_block: Write failed -1 of 476 bytes from 0x893c0b4 at 0x0 block 81920 errno 10
(41.832028) [ERR  netsurf] content/fs_backing_store.c:1623 store_write_block: Write failed -1 of 466 bytes from 0x893c0b4 at 0x0 block 90112 errno 11
(41.921201) [ERR  netsurf] content/fs_backing_store.c:1623 store_write_block: Write failed -1 of 466 bytes from 0x893c0b4 at 0x0 block 98304 errno 12
(41.989624) [ERR  netsurf] content/fs_backing_store.c:1623 store_write_block: Write failed -1 of 466 bytes from 0x893c0b4 at 0x0 block 106496 errno 13
(42.059452) [ERR  netsurf] content/fs_backing_store.c:1623 store_write_block: Write failed -1 of 461 bytes from 0x893c0b4 at 0x0 block 114688 errno 14
(42.127641) [ERR  netsurf] content/fs_backing_store.c:1623 store_write_block: Write failed -1 of 469 bytes from 0x893c0b4 at 0x0 block 122880 errno 15
(42.186718) [ERR  netsurf] content/fs_backing_store.c:1021 set_store_entry: attempt to overwrite entry with in use data
(42.234155) [ERR  netsurf] content/fs_backing_store.c:1716 store: store entry setting failed
(42.270241) [ERR  netsurf] content/fs_backing_store.c:1021 set_store_entry: attempt to overwrite entry with in use data
(42.317446) [ERR  netsurf] content/fs_backing_store.c:1716 store: store entry setting failed
(42.352894) [ERR  netsurf] content/fs_backing_store.c:1021 set_store_entry: attempt to overwrite entry with in use data
(42.400234) [ERR  netsurf] content/fs_backing_store.c:1716 store: store entry setting failed
(42.435514) [ERR  netsurf] content/fs_backing_store.c:1021 set_store_entry: attempt to overwrite entry with in use data
(42.484688) [ERR  netsurf] content/fs_backing_store.c:1716 store: store entry setting failed

That's the disk cache not working.  I've now raised this here as nobody else had.  Hopefully Vince can either fix it or give me some pointers.
"Miracles we do at once, the impossible takes a little longer" - AJS on Hyperion
Avatar picture is Tabitha by Eric W Schwartz
 

Offline chris

Re: NetSurf OS3
« Reply #16 on: May 23, 2020, 01:52:51 PM »
@Tygre (or anybody else who wants to help)

Please can you try again with the latest build, and paste the logs as a note/attachment into the bug report here: https://bugs.netsurf-browser.org/mantis/view.php?id=2760

Thanks!
"Miracles we do at once, the impossible takes a little longer" - AJS on Hyperion
Avatar picture is Tabitha by Eric W Schwartz
 

Offline utri007

Re: NetSurf OS3
« Reply #17 on: May 24, 2020, 12:06:56 AM »
I tried to make a log, but failed. Netsurf doesn't exit nicely, so log file is in use and cannot be copied. After reset I couldn't found log file anymore.
ACube Sam 440ep Flex 800mhz, 1gb ram and 240gb hd and OS4.1FE
A1200 Micronic tower, OS3.9, Apollo 060 66mhz, xPert Merlin, Delfina Lite and Micronic Scandy, 500Gb hd, 66mb ram, DVD-burner and WLAN.
A1200 desktop, OS3.9, Blizzard 060 66mhz, 66mb ram, Ide Fix Express with 160Gb HD and WLAN
A500 OS2.1, GVP+HD8 with 4mb ram, 1mb chip ram and 4gb HD
Commodore CDTV KS3.1, 1mb chip, 4mb fast ram and IDE HD
 

Offline x303

Re: NetSurf OS3
« Reply #18 on: May 24, 2020, 11:05:31 AM »
During browsing it says (a lot):

Severity 2: structure is not cleared
PC=138F7926 TCB=14E9AAC8 ("Background CLI")
1728 19358E64 00000000 00000000 13996A9C 00000001 151D195E
Addr: 19358E64 19358E60 19358DFC 151D195A 182D948E 151D183C 120008F4 151D1824
Stck: 138F792A 0000002E 138F7864 0000002A 00000000 13996840 151D184C 13993E24
Stck: 00000000 151D195A 151D1858 13993D4600E0 19359A94 193587B0 19358620 13965E48 00000003 151D1CB6
Addr: 19359A94 19359A90 193598C4 193587AC 182D948E 151D19BC 120008F4 151D19A4
Stck: 138F792A 0000002E 138F7864 0000002A 193589C5 13965E36 151D19C8 1392CC4C
Stck: 193587AC 151D19D8 13965FE2 193587AC 00000002 151D19F0 13965DD8 193587B4

and on exit it says:

Task  : 13B0E360 "NetSurf"
Error : 0100000F (Recoverable)
By    : ExecLibrary
Cause : Memory header not located
--------------------------------------------------------------------------------

or

Task  : 14E9AAC8 "NetSurf"
Error : 80000003 (DEADEND)
By    : System: no alert occured
Cause : Illegal address access (ie: odd)
--------------------------------------------------------------------------------

 

Offline chris

Re: NetSurf OS3
« Reply #19 on: May 24, 2020, 05:02:23 PM »
@utri007 Just copy and paste from the console, don't need a full log just the backing store stuff which ends up being output anyway.  You can copy it from the console directly into the bugtracker 😁

@x303 That would be interesting if I knew which structure it was complaining about.
« Last Edit: May 24, 2020, 05:03:01 PM by chris »
"Miracles we do at once, the impossible takes a little longer" - AJS on Hyperion
Avatar picture is Tabitha by Eric W Schwartz
 

Offline Tygre

Re: NetSurf OS3
« Reply #20 on: May 25, 2020, 03:58:04 AM »
Hi Chris!

@Tygre (or anybody else who wants to help)

Please can you try again with the latest build, and paste the logs as a note/attachment into the bug report here: https://bugs.netsurf-browser.org/mantis/view.php?id=2760

Thanks!

Will try very soon :)

Cheers!
Tygre

Offline utri007

Re: NetSurf OS3
« Reply #21 on: May 25, 2020, 07:03:43 AM »
ACube Sam 440ep Flex 800mhz, 1gb ram and 240gb hd and OS4.1FE
A1200 Micronic tower, OS3.9, Apollo 060 66mhz, xPert Merlin, Delfina Lite and Micronic Scandy, 500Gb hd, 66mb ram, DVD-burner and WLAN.
A1200 desktop, OS3.9, Blizzard 060 66mhz, 66mb ram, Ide Fix Express with 160Gb HD and WLAN
A500 OS2.1, GVP+HD8 with 4mb ram, 1mb chip ram and 4gb HD
Commodore CDTV KS3.1, 1mb chip, 4mb fast ram and IDE HD
 

Offline Tygre

Re: NetSurf OS3
« Reply #22 on: May 26, 2020, 01:48:05 AM »
@Tygre (or anybody else who wants to help)

Please can you try again with the latest build, and paste the logs as a note/attachment into the bug report here: https://bugs.netsurf-browser.org/mantis/view.php?id=2760

Thanks!

Hi Chris!

I ran the latest build 5168 and got some errors and a Guru ???
I could not add them to the Mantis ticket because I could never register to Mantis: I never receive their validation e-mails ::)

So, I attach them here...
 
The following users thanked this post: chris