Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: IBrowse SSL proxy using squid?  (Read 248 times)

0 Members and 1 Guest are viewing this topic.

Offline slaapliedje

  • Lifetime Member
  • Hero Member
  • *****
  • Join Date: Oct 2010
  • Posts: 836
  • Country: 00
  • Total likes: 3
IBrowse SSL proxy using squid?
« on: November 30, 2019, 06:53:11 PM »
So, now that IBrowse 2.5 is out in the wild, I will say it's fast, much more compatible than 2.4, and really actually usable... EXCEPT when it's an SSL site, it is SLOW.  This is on my A4000 with an 060@50mhz.  The poor ol' girl was never meant to decrypt SSL. 

Now one of my A4000s has a PPC in it, which I dual boot OS3.9 and 4.1, and in 4.1 it's actually a decent speed, but since IBrowse only has a PPC version for OS4.1 and not one for 3.9, it's still slow there.

Now my thought about this is to set up squid as a proxy server for https from specific IP addresses internally.  Has anyone done this before?  If so, want to share some configs?  If not, I'll I'll work on it myself, then share it here.  Been a while since I played with Squid, but I know such a thing is possible.  Hell, had to do something similar for the PS3, since it had some weird issue with downloading things at anything higher than 30kb/s unless I connected it straight to the outside modem!
A4000D: Mediator 4000Di; Voodoo 3, ZorRAM 128MB, 10/100mb Ethernet, Spider 2. Cyberstorm PPC 060/50 604e/420.