Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Hollywood MAL AMIStore App Store A600 Memory

AuthorTopic: SSL Expired on Website  (Read 1294 times)

0 Members and 1 Guest are viewing this topic.

Offline RussellB

SSL Expired on Website
« on: June 12, 2019, 12:27:24 PM »
It has come up today that the SSL certificate has expired for the amiga.org webite.
 

Offline nbache

Re: SSL Expired on Website
« Reply #1 on: June 12, 2019, 12:31:41 PM »
Aha - that also explains why (when using http which otherwise works) the sponsor ad images at the top of the page are not shown; their paths are specified with https.

Best regards,

Niels


 

Offline slaapliedje

  • Lifetime Member
  • Hero Member
  • *****
  • Join Date: Oct 2010
  • Posts: 833
  • Country: 00
  • Total likes: 2
Re: SSL Expired on Website
« Reply #2 on: June 13, 2019, 01:03:16 AM »
Oops, someone fall asleep at the helm?  Not sure who they buy their cert through, but I've always gotten at least a month's advance warning on mine.  Seems retro forums especially have issues with getting their certs correct.
A4000D: Mediator 4000Di; Voodoo 3, ZorRAM 128MB, 10/100mb Ethernet, Spider 2. Cyberstorm PPC 060/50 604e/420.
 

Offline nbache

Re: SSL Expired on Website
« Reply #3 on: June 13, 2019, 10:37:59 AM »
Seems to have been fixed.

Best regards,

Niels
 

Offline paul1981

Re: SSL Expired on Website
« Reply #4 on: June 14, 2019, 11:18:15 AM »
Seems to have been fixed.

Best regards,

Niels

Half the time I get an unsecure connection to this forum and I have to go back to amiga.org and then back to the forum to get a https connection to it (sometimes many times before it works). Does anyone else have this problem? I use Firefox and Vivaldi...
 

Offline F0LLETT

Re: SSL Expired on Website
« Reply #5 on: June 14, 2019, 11:29:02 AM »
Only time that would happen, is if you use a link that is http. Then it will stay as http. I will ask to sort this out, as I have done on my own sites.
Quote from: Hungry Horace
Resolute and Industrious Grand ruler of the yellow people and the Ultimate Amiga Empire
Ultimate Amiga Network (Home of SONY PSP Amiga Emulator and AMOS Factory)

Quote from:  He who shall not be named
"Chris is that you!!!"
My all time favorite quote.
 

Offline paul1981

Re: SSL Expired on Website
« Reply #6 on: June 14, 2019, 03:03:18 PM »
I start from here http://www.amiga.org/ (not secure)

From there I click on the forum and it's pot luck whether I get a secure connection or not. If I don't I have to go back from the start and click on forum again until it gets a secure connection.

Out of interest, I do select the 'keep me signed in' part and just now I have navigated off of the site to a search engine, then searched for amiga.org and I then clicked the link to take me into the forum and it is no longer a secure connection yet I am still signed in (and posting this very post).

 

Offline amigakit

Re: SSL Expired on Website
« Reply #7 on: June 14, 2019, 04:43:57 PM »
Quote
I start from here http://www.amiga.org/ (not secure)

From there I click on the forum and it's pot luck whether I get a secure connection or not.

I fixed this, please let me know if it now consistently takes you to https://forums.amiga.org
www.AmigaKit.com - Amiga Hardware/Software Dealer

New Products  --   Customer Help & Support -- @amigakit

USA Toll Free Order Tel: 1-888-698-6758
 

Offline paul1981

Re: SSL Expired on Website
« Reply #8 on: June 15, 2019, 12:23:39 AM »
Quote
I start from here http://www.amiga.org/ (not secure)

From there I click on the forum and it's pot luck whether I get a secure connection or not.

I fixed this, please let me know if it now consistently takes you to https://forums.amiga.org

It appears to be okay this evening after you've done your stuff. I'll keep an eye on it and report back here in a few days to confirm it's fixed.

Offline paul1981

Re: SSL Expired on Website
« Reply #9 on: June 18, 2019, 11:44:51 AM »
It appears to be consistantly giving me a secure connection now which is good. Having said this, if I navigate away to my home page (set to Startpage the search engine) and then do a search for amiga forums and select the amiga.org link, the link is still the non-secure one (expected I suppose at the moment) and selecting it navigates to it but on the non-secure http:// not the https://...yet it still leaves me logged in. Whether that is normal or not I don't know.
Other secure sites I have tried re-direct to https:// if a non-secure URL is specified. Again, I don't know what is usual or normal here in this case, but I can now get a consistent secure connection so I am happy about that, thank you.
 

Offline amigapassion

Re: SSL Expired on Website
« Reply #10 on: September 11, 2019, 09:25:49 AM »
SSL needs to be renewed
Offering Amiga 500,600,1200,4000,4000T as well as Amiga 500,1500,2000,3000 recapping services as well as minor repairs.
 

Offline kolla

Re: SSL Expired on Website
« Reply #11 on: September 11, 2019, 10:33:49 AM »
SSL needs to be renewed
It's a certificate from Let's Encrypt, so apparently...
* the certificate bot/cronjob/whatever that's supposed to handle auto-renewals is not working
* there is no monitoring of the certificate, or whoever is supposed to monitor it, or act on alarms, didn't.
(and the same is probably true for other services too)

One would think that Amikit/A-Eon would be capable of at least monitor their own few services.
« Last Edit: September 11, 2019, 10:35:27 AM by kolla »
B5D6A1D019D5D45BCC56F4782AC220D8B3E2A6CC