Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Hollywood MAL AMIStore App Store A600 Memory

AuthorTopic: AmiDock and 3.1.4  (Read 522 times)

0 Members and 1 Guest are viewing this topic.

Offline Munchkin

AmiDock and 3.1.4
« on: January 15, 2019, 08:31:50 PM »
Gotten used to having AmiDock so I wanted that in my new and fresh 3.1.4 install. However, it won't start and asks for resource.library v44. I copied the resource.library from my old 3.9 installation but it still asks for it when I try to start it.

Ben running snoopdos to see if I can get some kind of clue. At first it looked for said library but after I copied that it stopped searching for it, however it does search for a bunch of .gadget's that I don't have and didn't have in the old installation either.

Isn't this program compatible with 3.1.4, is it somehow locked to only work with 3.9? Has anyone else got it working?
 

Offline Munchkin

Re: AmiDock and 3.1.4
« Reply #1 on: January 15, 2019, 11:43:05 PM »
Never mind. All sorted. Just some bad programming I guess since it says the library isn't found no matter what file it can't find. Found all the necessary files on my old installation, just forgotten where stuff are stored.
 

Offline SnkBitten

  • Full Member
  • ***
  • Join Date: Feb 2016
  • Posts: 108
  • Country: us
  • Total likes: 1
  • Gender: Male
  • Amithlon Fanatic
    • http://amithlon.snkbitten.com
Re: AmiDock and 3.1.4
« Reply #2 on: January 16, 2019, 11:19:27 AM »
Care to share which files you needed to copy over? I use Amidock on my 3.9 setup but have started a fresh 3.1.4 install on my A4000 and would like to have Amidock working with it as well.

Offline Munchkin

Re: AmiDock and 3.1.4
« Reply #3 on: January 16, 2019, 04:05:49 PM »
You need resource.library, a bunch of class-files and a few datatypes installed. Don't really remember which ones. If you use Snoopdos you'll see what it's looking for. It'll work without the datatypes but you won't get any backgrounds, it'll just be plain gray. I just copied all the class files, all datatypes and the lib and that's it if I remember correctly.