Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A600 Memory

AuthorTopic: New to Winuae  (Read 449 times)

0 Members and 1 Guest are viewing this topic.

Offline foleyjo

New to Winuae
« on: April 08, 2016, 08:24:46 AM »
Hi all,

I've recently started using Winuae with Amikit and just have a few questions that I was hoping people could help with

Bit of background (feel free to ignore and go down to question 1)
Im using a pipo x9 (http://www.makeuseof.com/tag/pipo-x9-hybrid-windows-10-android-mini-pc-review/) with the latest version of Winuae with the latest version of amikit (I installed amikit then installed the latest Winuae as it seems to have more features than the one included in amikit)
I'm not new to Amigas and have an A1200 with 060 and 64mb ram. I am new to Winuae, Amikit and RTG stuff.
I use my pipo mainly for retro gaming on the windows side and film watching on the android side.
I'm trying to get a setup where I can use Amiga OS as my main OS to keep with the retro feel of things. .


1 - I'm trying to use winlaunch to open windows apps from within workbench but it just gives me an error asking me to either jump rts, change pc or remove. This is even when using the preinstalled icons to open internet explorer or firefox. Any tips on how to get this working would be nice.
2 - Is it normal for doom to play on a tiny screen when selecting a high resolution? I think I'm using Adoom. Other games where I can use the uaegfx screenmodes also had smaller screens till I switched to Full-Window rather than Full screen in the display settings. Doom is always tiny until I select a very low resolution (around 300 and somthing)

3 - How do I get scummvm (the preinstalled amikit version) into fullscreen. Instructions say Alt+enter but alt+enter doesn't seem to work. (Looking at the software list I may need to use the AGA version is this correct)

4 - I've read that Winuae is compatible with OS4 now. Is there a demo/timetrial version of OS4 available? I'd like to test it before I commit to a purchase. I'm not sure how well it will perform on my device. The Pipo X9 isn't overly powerful but gives good Amiga performance.

5 - Is netsurf supposed to be really slow and cause lockups while pages are loading? Ibrowse and aweb run fast but netsurf crawls. (I actually have a button on my keyboard that opens up chrome on top of the UAE window making it look like it's actually running in workbench so I'm not too bothered about this. It's more of a curiosity thing)

6 - When selecting the video card expansions is it better to use the UAE-picasso or picasso IV?

7 - I wasn't getting the best performance (especially with icons and backgrounds loading) until I installed fblit and blazewcp. Is there any other speed up software that you can think of that I should definitely be trying? (I removed MCP because it caused problems with stability)

Thanks in advance
 

Offline Thomas

Re: New to Winuae
« Reply #1 on: April 08, 2016, 12:12:36 PM »
1) You have to enable the "allow native code" option on the Misc panel. Be aware that this is a potential security breach because it allows to execute x86 code without control of your anti-virus software.

2) I think this is about host resolution versus Amiga resolution. You might have to change the ADoom config file or command line arguments to get a higher resolution. All you can get from WinUAE is small resolution scaled to a big screen, making it all blurry. Anyway to get the scaling active you should check the Filters panel.

3) no idea.

4) there is no trial version. But if netsurf is slow, OS4 will be even slower.

5) no idea.

6) uaegfx gives more direct access to the host gfx card, it automatically clones all available gfx modes of the PC's gfx card. PicassoIV emulates the Picasso hardware with all its restrictions. It's more for the retro feeling than for productivity. Note that uaegfx does not yet work with OS4 unless you use a beta version of WinUAE.

7) if you use uaegfx modes you should see it fly without any patches. Fblit and the like are only needed when using the Amiga's native chipset. And on WinUAE it shouldn't make a difference at all unless you use very strict compatibility settings like cycle-exact, approximate a500 speed and the like.

If you use the "high end" quickstart setting, you should get the fastest Amiga you've ever seen.

Offline foleyjo

Re: New to Winuae
« Reply #2 on: April 08, 2016, 01:25:27 PM »
Thanks Thomas, I'll have another play around with the settings after work based on your answers.

I must have something set wrong if you say I shouldn't need fblit as loading was slow without it.
 

Offline Thomas

Re: New to Winuae
« Reply #3 on: April 08, 2016, 02:09:26 PM »
Quote
I must have something set wrong


Well, "wrong" is relative.

You have to see WinUAE as a universal program which can do everything. It can be highly accurate on one hand or really fast on the other hand or anything inbetween.

Accuracy also means that the speed is accurate, i.e. as slow as a real Amiga. So if your goal is accuracy and emulation is slow, then the goal is reached.

On the other hand you can increase speed dramatically if you reduce accuracy.

These are the settings used for speed:

CPU:
- 68020 or higher
- JIT
- fastest possible

Chipset:
- generic
- immediate blitter
- *no* cycle exact

Floppy drives:
- turbo

RTG board:
- UAE ZorroIII (a.k.a. uaegfx)

Software-wise you have to install Picasso96 software, otherwise the uaegfx card is not used.

Offline foleyjo

Re: New to Winuae
« Reply #4 on: April 08, 2016, 02:39:10 PM »
My goal is definitely speed.
I've got my A1200 for accuracy
 :)
 

Offline foleyjo

Re: New to Winuae
« Reply #5 on: April 08, 2016, 05:24:09 PM »
I've adjusted my settings slightly and removed fblit and blazewcp from the startup sequence and everything is still running nice and fast.
I've made sure the native code option is ticked but I still get the error,
It says "DEADEND" Line1010 Emulator error

My setup

CPU:
- 68060
- JIT
- fastest possible

Chipset:
- A4000

Expansions
-P5 Cyberstorm (with software installed)

RTG board:
- UAE ZorroIII (Picasso software already installed by amikit)
 

Offline foleyjo

Re: New to Winuae
« Reply #6 on: April 08, 2016, 06:05:32 PM »
Just tried in the Amikit version of winuae and winlaunch work. Not sure if it's a problem with the latest winuae. The only setting thats different is the cyberstorm ppc because it's not available on the amikit version.
I turned it off on the latest winuae but it didn't fix the problem.
Not sure if I really need the PPC as it doesn't seem to make much of a difference
 

Offline foleyjo

Re: New to Winuae
« Reply #7 on: April 14, 2016, 08:07:58 AM »
Sorry to bring this up again but I'm having a few issues.
 Has anyone experienced any of the following and if so how did you fix them?

1 - Sometimes when I boot up during the wbstartup folder loading, execute stops working. It lets me open folders but I can't launch anything. After a few minutes it will then start again. Anyway to see what is being loaded or is it a simple case of removing everything and putting it back 1 at a time. As it's random this approach may not be that useful

2 - After I use the mouse wheel sometimes it causes the scroll bars to go off on their own, or the windows to start flickering or one of the axis of the mouse to stop working. Alt-Tabbing to a windows app and back can sometimes fix this. If not a reset.

3 - Sometimes when typing instead of the characters I expect I get weird characters that I've never seen before (ie:not shown on the keyboard) and delete stops working. I have to use the Alt-Tab method from above to get it working again.

4 - I tried Wipeout. I wasn't expecting much from it and reading up on it I probably won't bother with it anymore as I read about having to use a few patches to get thngs working with PPC and warpos. Things I don't understand. However 1 thing that does puzzle me is when i select a screenmode no screenmodes are displayed. I know I'm supposed to have 16bit screens available and when I select screenmodes for other apps/games 16 bit modes are listed.

5 - Should I be bothering with the Cyberstorm PPC when using Winuae? I'm not sure how needed it really is, I just know that some software says it recommends PPC. If some apps/games will benefit from it then I'll leave it on. If its pointless when using UAEGfx then I'll disable it.