Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Hollywood MAL AMIStore App Store A600 Memory

AuthorTopic: Backdrops/Wallpapers look wrong in OS 3.1  (Read 854 times)

0 Members and 1 Guest are viewing this topic.

Offline Yasu

Backdrops/Wallpapers look wrong in OS 3.1
« on: February 03, 2016, 05:49:51 PM »
I have gotten myself a MiST and am currently trying to pimp my workbench so it reminds me of how my A1200 used to look like around 1997. It came with an HDF with pre-installed MWB and I've installed NewIcons over it. Problem is that I want to use a backdrop/wallpaper that has 21 colors in it, but while I can get it to show the correct colors when I use a 256 color screen, anything below that (128, 64 or 32 colors) will show the backdrop with the wrong colors.

What can I do to fix this?

Offline Oldsmobile_Mike

Re: Backdrops/Wallpapers look wrong in OS 3.1
« Reply #1 on: February 03, 2016, 07:31:44 PM »
That's normal.  Workbench is adapting the colors to match your available palette.  Try locking the palette using a program like FullPalette or similar.

Read this guide:  http://www.mfilos.com/2012/01/guide-making-workbench-prettier-using.html

And download this program:  http://aminet.net/package/util/wb/FullPalette22

While you're at it, you probably want this, too:  http://aminet.net/package/util/libs/IconLib_46.4
Amiga 500: 2MB Chip|16MB Fast|30MHz 68030+68882|3.9|Indivision ECS|GVP A500HD+|Mechware card reader + 8GB CF|Cocolino|SCSI DVD-RAM
Amiga 2000: 2MB Chip|136MB Fast|50MHz 68060|3.9|Indivision ECS + GVP Spectrum|Mechware card reader + 8GB CF|AD516|X-Surf 100|RapidRoad|Cocolino|SCSI CD-RW
 Amiga videos and other misc. stuff at https://www.youtube.com/CompTechMike/videos
 

Offline Yasu

Re: Backdrops/Wallpapers look wrong in OS 3.1
« Reply #2 on: February 03, 2016, 09:39:44 PM »
Thanks. I tried using Fullpalette before but I wasn't able to get the color I wanted. But now I tried again, and after upping to 64 colors (giving me the right palette), locking the colors and then reducing to 32 colors again it worked! Thanks :)

Offline Oldsmobile_Mike

Re: Backdrops/Wallpapers look wrong in OS 3.1
« Reply #3 on: February 03, 2016, 11:12:09 PM »
Quote from: Yasu;803451
Thanks. I tried using Fullpalette before but I wasn't able to get the color I wanted. But now I tried again, and after upping to 64 colors (giving me the right palette), locking the colors and then reducing to 32 colors again it worked! Thanks :)

Excellent!


Amiga 500: 2MB Chip|16MB Fast|30MHz 68030+68882|3.9|Indivision ECS|GVP A500HD+|Mechware card reader + 8GB CF|Cocolino|SCSI DVD-RAM
Amiga 2000: 2MB Chip|136MB Fast|50MHz 68060|3.9|Indivision ECS + GVP Spectrum|Mechware card reader + 8GB CF|AD516|X-Surf 100|RapidRoad|Cocolino|SCSI CD-RW
 Amiga videos and other misc. stuff at https://www.youtube.com/CompTechMike/videos