Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: Dopus5 ftp.module compatibility issues?  (Read 439 times)

0 Members and 1 Guest are viewing this topic.

Offline Firestone

Dopus5 ftp.module compatibility issues?
« on: November 22, 2014, 01:38:30 PM »
Anyone here have some experience with the FTP-module in Dopus5?
I got 5.82 installed on my A1200, and the FTP-module in Dopus have always worked for me.
I haven't used it for years now, but suddenly it hangs on "Reading Directory /" an nothing more happens.

Tried to upgrade to the newest open source versions of Dopus5, but same thing happens. Sometimes I get "Querying for FTP server type" or something like that in the newer version, but can't get a listing of the directory on the FTP-server.

Have tried different servers both on OS X and on my Linux server, but the same thing happens.

Tried AmiTraceCenter, and everything there works fine. Sadly it's more convinient to use Dopus as I do all my work there :)

Tried several other old FTP-clients for the Amiga too, and some of them are failing too.
Did something happen to the FTP-standards that prevent these old clients to get a connection?
 

Offline paolone

Re: Dopus5 ftp.module compatibility issues?
« Reply #1 on: November 22, 2014, 05:56:32 PM »
Server on the other side may have switched to passive transfer mode. Do the same in advanced options of your address book.
p.bes

 

Offline pVC

Re: Dopus5 ftp.module compatibility issues?
« Reply #2 on: November 22, 2014, 06:13:52 PM »
Yeah, sounds like passive mode issue. It's all about your and server's firewall rules. In active mode (which might be the default in certain ftp clients) data connections (directory listings, file transfers) are made from server to client.. it means client must have data ports open and not blocked by firewall etc. In most cases you don't have them open nowadays when you're behind  routers etc.

With passive mode it's up to server to have everything needed open and client settings don't affect. It's usually made this way nowadays. So, check your client options and enable passive mode from it. All clients should have this switch in a way or another.

In DopusFTP it's found from ftp site's custom options, in miscellaneous page. DopusFTP should work just fine nowadays too, I'm using it regularly still (the original 5.82).
« Last Edit: November 22, 2014, 06:17:09 PM by pVC »
Daily MorphOS user and Amiga active.
 

Offline Ancalimon

Re: Dopus5 ftp.module compatibility issues?
« Reply #3 on: November 22, 2014, 06:14:45 PM »
There is the 5.90 version which is still getting updates (currently at 5.91 beta). Maybe try it to see if anything changes. As far as I know ftp module had some bugs fixed.

http://dopus5.org/
A4000T, 604e@400&060@66, 128MB+16MB+Zorram256, CVisionPPC, VLabMotion, Toccata, XSurf100&RapidRoad, Prisma Megamix

A1200, Blizzard060@50, 256MB, Blizzard IV SCSI, FastATA mk4
 

Offline Firestone

Re: Dopus5 ftp.module compatibility issues?
« Reply #4 on: November 22, 2014, 06:51:59 PM »
Ahh.... perfect you two guys!

Enabled passive transfer in Dopus-FTP and it all worked like a charm :)
Thanks a lot!

There aren't any SFTP-clients out there for m68k Amigas by the way? :)