Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: A1200 Short circuited pin 150 -12v with pin 149 +12v repair  (Read 1024 times)

0 Members and 1 Guest are viewing this topic.

Offline AmiJIm

A1200 Short circuited pin 150 -12v with pin 149 +12v repair
« on: October 27, 2013, 05:48:37 PM »
Hello there,this afternood i was installing the acard scsi to ide to CF adaptoer to my blizzard 1230-iv scsi and the metal shield touched to pins of the blizzy.the pin 150 which is actually -12v and pin 149 which is +12v.a line was burnt from pin 150 to a capacitor near CIA .The amiga 1200 powers on OK , but it freezes moments after i use the mouse.I resolder the trace ,still same problem.Is the CIA to blame,shall i replace them or there must have be done some more damage and i shall buy a new motherboard?Also i noticed that the big black barrel capacitor near the cia has enlarged itself,can this problem be because i need to recap my mobo?what shall i do and where i could find CIA chips?
thank you .
 

Offline Zac67

Re: A1200 Short circuited pin 150 -12v with pin 149 +12v repair
« Reply #1 on: October 27, 2013, 06:34:37 PM »
If a capacitor has a bulged cap or 'wet' feet it needs to be replaced. Can't guarantee that it solves the problem tho...
 

Offline gertsy

  • Lifetime Member
  • Hero Member
  • *****
  • Join Date: May 2006
  • Posts: 2306
  • Country: au
  • Total likes: 5
    • http://www.members.optusnet.com.au/~gbakker64/
Re: A1200 Short circuited pin 150 -12v with pin 149 +12v repair
« Reply #2 on: October 27, 2013, 09:18:48 PM »
Id replace the one cap first. Then if that doesn't fix it send it to a professional to attempt to repair and replace all the caps, if they find the problem.  Alternatively you could source a used or refurbished A1200 for probably close to the same price of the repairs and postage. I know it doesn't help but I have thick insulation tape on the edge of the shielding next to the edge connector.
 

Offline AmiJIm

Re: A1200 Short circuited pin 150 -12v with pin 149 +12v repair
« Reply #3 on: November 22, 2020, 08:42:37 PM »
After  some years of inactivity and having changed the caps by a professional , the blizzard was not working.It would lock up after 4 minutes of usage.Every time.It turns out that all i had to do was to remove the E123C and E125C as per Ians instructions and now the amiga works like new.Note than back in 1994 when i bought new the A1200 and the blizzard 1230iv it was working with the resistors in place.Salute!