Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Hollywood MAL AMIStore App Store A600 Memory

AuthorTopic: OS 3.1 applications under OS 4.1  (Read 2368 times)

0 Members and 1 Guest are viewing this topic.

Offline Iggy

OS 3.1 applications under OS 4.1
« on: January 27, 2014, 12:40:45 AM »
OK, an naive question here.
If Hyperion has the right to use OS 3.1 source, why doesn't OS 4.1 have better legacy compatibility (at least as good or better than say a PC running Amiga Forever)?
"Not making any hard and fast rules means that the moderators can use their good judgment in moderation, and we think the results speak for themselves." - Amiga.org, terms of service

"You, got to stem the evil tide, and keep it on the the inside" - Rogers Waters

"God was never on your side" - Lemmy

Amiga! "Our appeal has become more selective"
 

Offline giZmo350

Re: OS 3.1 applications under OS 4.1
« Reply #1 on: January 27, 2014, 01:18:40 AM »
A lot of legacy apps do run on OS4.X
This site was created just for the express purpose to show which legacy apps have been tested under OS4.X

http://www.intuitionbase.com/ossoftware.php

As far as Amiga Forever goes, it doesn't emulate OS4.X
Also, there's no way anyone is going to rewrite a majority of the legacy apps to run native under OS4.X
A500: 2MB Chip, 8MB Fast, IndiECS, MiniMegi, IDE4ZorroII on Z-500, KS1.3/KS3.1, WB3.1&BWB
 
A2000HD: 2MB Chip, 128MB Fast, P5:Blizz 2060@50MHz, PCD-50B/4GBCF, XSurf100, RapidRoad, IndiECS, Matze RTG, MiniMegi, CD-RW, SunRize AD516, WB3.9
 
A1200: 2MB Chip, 64MB Fast, 4GBCF, GVP Typhoon 030 @40MHz w/FPU, Subway USB, EasyNet Ethernet, Indi AGA MKI, FastATA MK-IV, Internal Slim CD/DVD-RW, WB3.5

"The internet doesn't weigh anything Jen
 

Offline Matt_H

Re: OS 3.1 applications under OS 4.1
« Reply #2 on: January 27, 2014, 03:03:10 AM »
@ Iggy

I'm guessing the issue has something to do with the particular way they re-implemented and expanded the APIs on the OS4-native versions of the libraries (dos.library springs to mind as being particularly full of changes). They also had to convert a lot of code from assembler (and possibly some BCPL) to C, so there could be some margin for error there. Another possible factor is that the Petunia 68K JIT isn't perfect. There is the Compatibility prefs editor to help with older software, but it's almost impossible to use - I had to do all my edits in a text editor instead (and then I'm not sure it actually made a difference).

The unspoken question here is why 68K compatibility is better under MorphOS. A few factors that could be involved there are: the project got started much earlier than OS4, so more time to work out bugs; more consistent project management and project team, so fewer loose ends of components left hanging; and more experienced developers - Ralph Schmidt, the CGX guys, and many others had years of deep hardware/software knowledge of the Amiga before getting into MorphOS. I think fewer of the OS4 devs have that level of experience.

@ all

That being said, let's not have this devolve into another OS4/MOS flamefest, okay? I think we can have a nice, adult conversation about software compatibility...
 

Offline smf

Re: OS 3.1 applications under OS 4.1
« Reply #3 on: January 27, 2014, 05:58:01 AM »
@Iggy

Do you have any particular software in mind that doesn't run and how the hell can you think that compatiblity should be higher than under emulation in winuae?

If some old software isn't working in os4, just let it be started from uae. So compatiblity is probably the best in any amigaos ever since you can run both amigaos4 exes & classic executables.
 

Offline nicholas

Re: OS 3.1 applications under OS 4.1
« Reply #4 on: January 27, 2014, 09:41:32 AM »
Octamed
Quote
Sound Studio doesn't work on MorphOS, so that's one stick in the eye that OS4 has over it when it comes to compatibility with 68k apps.

It's a pretty major Amiga app too.
« Last Edit: January 27, 2014, 09:44:41 AM by nicholas »
“Een rezhim-i eshghalgar-i Quds bayad az sahneh-i ruzgar mahv shaved.” - Imam Ayatollah Sayyed  Ruhollah Khomeini
 

Offline nicholas

Re: OS 3.1 applications under OS 4.1
« Reply #5 on: January 27, 2014, 09:44:12 AM »
Quote from: Iggy;757963
OK, an naive question here.
If Hyperion has the right to use OS 3.1 source, why doesn't OS 4.1 have better legacy compatibility (at least as good or better than say a PC running Amiga Forever)?

The MorphOS team consists of some of the creme de la creme of Amiga developers from back in the day.

I'm not saying the OS4 devs are sh1t but they are not of the same calibre. Not even close.
“Een rezhim-i eshghalgar-i Quds bayad az sahneh-i ruzgar mahv shaved.” - Imam Ayatollah Sayyed  Ruhollah Khomeini
 

Offline nicholas

Re: OS 3.1 applications under OS 4.1
« Reply #6 on: January 27, 2014, 09:49:22 AM »
Quote from: smf;757984
@Iggy

Do you have any particular software in mind that doesn't run and how the hell can you think that compatiblity should be higher than under emulation in winuae?

If some old software isn't working in os4, just let it be started from uae. So compatiblity is probably the best in any amigaos ever since you can run both amigaos4 exes & classic executables.


MorphOS runs 68k, PowerUP, WarpOS/WarpUP, OS4 and MorphOS binaries.
OS4 runs  68k, WarpOS/WarpUP and OS4 binaries.
“Een rezhim-i eshghalgar-i Quds bayad az sahneh-i ruzgar mahv shaved.” - Imam Ayatollah Sayyed  Ruhollah Khomeini
 

Offline utri007

Re: OS 3.1 applications under OS 4.1
« Reply #7 on: January 27, 2014, 10:16:51 AM »
Quote from: Iggy;757963
OK, an naive question here.
If Hyperion has the right to use OS 3.1 source, why doesn't OS 4.1 have better legacy compatibility (at least as good or better than say a PC running Amiga Forever)?


I have tested quite many 68k apps and most of them run perfectly under OS4

I have to admit that I haven't tested any music apps.

There is a huge difference how UEA and Petunia handle emulation. UEA emulates whole Computer, wich means speed drop. Petunia emulates only cpu, it uses PPC native libraries etc if they are availlable, so when you start app, it is possible that only exe, runs under emulation, libraries etc are runned in native.

Some system friendly games are running under petunia, Graphics are done with native PPC drivers and sound is done with PPC native AHI. UEA emulates all of them.

When it is possible to use Petunia performance is very good, it is like no emulation at all.

With RunInUEA it possible to run whdload games etc direcly from icon.
ACube Sam 440ep Flex 800mhz, 1gb ram and 240gb hd and OS4.1FE
A1200 Micronic tower, OS3.9, Apollo 060 66mhz, xPert Merlin, Delfina Lite and Micronic Scandy, 500Gb hd, 66mb ram, DVD-burner and WLAN.
A1200 desktop, OS3.9, Blizzard 060 66mhz, 66mb ram, Ide Fix Express with 160Gb HD and WLAN
A500 OS2.1, GVP+HD8 with 4mb ram, 1mb chip ram and 4gb HD
Commodore CDTV KS3.1, 1mb chip, 4mb fast ram and IDE HD
 

Offline Rob

Re: OS 3.1 applications under OS 4.1
« Reply #8 on: January 27, 2014, 01:47:49 PM »
Quote from: Iggy;757963
OK, an naive question here.
If Hyperion has the right to use OS 3.1 source, why doesn't OS 4.1 have better legacy compatibility (at least as good or better than say a PC running Amiga Forever)?


Stating the obvious but when running Amiga forever you are emulating the complete systems so if you're running 3.x then pretty much everything written for it runs.

With OS4.x or MorphOS you'll find that most apps that don't work fail because a particular piece of hardware isn't present.  If you ever ran Amithlon you'd have found the same problems even though there were no changes to the API and feature set like with 4.x and MorphOS.

On OS4.x you have the P96 fake native modes and there are some little third party utils called CIAgent and Blitzen which may help some software to run.  There maybe be similar stuff on MorphOS but I haven't used it extensively and sold my Efika on a long time ago.

Having said that, as someone who went from using a 3.x system to 4.x system for everyday computing I don't recall anything significant that I could no longer use.
 

Offline Iggy

Re: OS 3.1 applications under OS 4.1
« Reply #9 on: January 27, 2014, 02:24:32 PM »
OK, like I said, naive on my part as I have not had a lot of opportunity to work with OS4.
Hey Nik, what gives you the idea we can run OS4 binaries?
I haven't had a lot of luck with that.
And Octamed is significant (did anyone ever suspect I'd be making the OS4 argument?)
As to the differences inherent in 3.1 vs 4.1 system calls, if necessary the entire body of 3.1 could be incorporated and interpreted.

And UAEs hardware emulation?
Why not go that route?
When MorphOS was introduced, the hardware didn't have the power to consider that option, but what we are running our OS' on now certainly does.

And why not do it better than X86 based UAE?
There are obvious advantages.
For one, UAE can't run the PPC binaries.

Ideally, an NG OS would run legacy apps and NG apps concurrently, seamlessly as if everything was native.

At that point, the arguments against transition evaporate.
"Not making any hard and fast rules means that the moderators can use their good judgment in moderation, and we think the results speak for themselves." - Amiga.org, terms of service

"You, got to stem the evil tide, and keep it on the the inside" - Rogers Waters

"God was never on your side" - Lemmy

Amiga! "Our appeal has become more selective"
 

Offline nicholas

Re: OS 3.1 applications under OS 4.1
« Reply #10 on: January 27, 2014, 02:40:54 PM »
“Een rezhim-i eshghalgar-i Quds bayad az sahneh-i ruzgar mahv shaved.” - Imam Ayatollah Sayyed  Ruhollah Khomeini
 

Offline Iggy

Re: OS 3.1 applications under OS 4.1
« Reply #11 on: January 27, 2014, 02:47:20 PM »
Quote from: nicholas;758010
http://amigazeux.net/os4emu/

Yes, I have seen that wrapper, I just have not been able to get it to do anything useful.
"Not making any hard and fast rules means that the moderators can use their good judgment in moderation, and we think the results speak for themselves." - Amiga.org, terms of service

"You, got to stem the evil tide, and keep it on the the inside" - Rogers Waters

"God was never on your side" - Lemmy

Amiga! "Our appeal has become more selective"
 

Offline nicholas

Re: OS 3.1 applications under OS 4.1
« Reply #12 on: January 27, 2014, 03:02:04 PM »
Quote from: Iggy;758011
Yes, I have seen that wrapper, I just have not been able to get it to do anything useful.

Well it runs x amount of programs from OS4  (mostly demos in my experience), which is x more programs than OS4 runs from MorphOS.

Even without that MorphOS is still compatible with more programs than OS4 making smf's claim an outright lie.
“Een rezhim-i eshghalgar-i Quds bayad az sahneh-i ruzgar mahv shaved.” - Imam Ayatollah Sayyed  Ruhollah Khomeini
 

Offline Methuselas

Re: OS 3.1 applications under OS 4.1
« Reply #13 on: January 27, 2014, 07:24:17 PM »
I wouldn't listen to Nic. He smells.....


REALLY *BAD*. :p:D
\'Using no way as way. Having no limitation as limitation.\' - Bruce Lee

\'No, sorry. I don\'t get my tits out. They\'re not actually real, you know? Just two halves of a grapefruit...\' - Miki Berenyi

\'Evil will always triumph because good is dumb.\' - Dark Helmet :roflmao:

\'And for future reference, it might be polite to ask someone if you can  quote them in your signature, rather than just citing them to make a  sales pitch.\' - Karlos. :rtfm: (I didn\'t ask, obviously......) :lol:
 

Offline nicholas

Re: OS 3.1 applications under OS 4.1
« Reply #14 on: January 27, 2014, 07:31:16 PM »
Quote from: Methuselas;758022
I wouldn't listen to Nic. He smells.....


REALLY *BAD*. :p:D

Indeed and because of that I'm not entitled to an opinion on any subject matter whatsoever in case others may convert to smelling really bad too. ;)
“Een rezhim-i eshghalgar-i Quds bayad az sahneh-i ruzgar mahv shaved.” - Imam Ayatollah Sayyed  Ruhollah Khomeini