Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A600 Memory

AuthorTopic: AmiWolf AGA - new Wolfenstein 3D Port  (Read 15287 times)

0 Members and 1 Guest are viewing this topic.

Offline commodorejohn

Re: AmiWolf AGA - new Wolfenstein 3D Port
« Reply #60 on: September 12, 2013, 07:09:01 PM »
Quote from: NovaCoder;747324
My best guess is that it's running out of memory, has anyone got it to run with only 16MB?

Did it create an ERROR.txt log in the game folder?
No errorlog, I'm afraid. I tried running it with 32MB as well, same result. (I'd be kind of astonished if a game that required 528KB on DOS required anything like even 16MB on the Amiga - even with the 4MB "MIDI instruments" file...)
Computers: Amiga 1200, DEC VAXStation 4000/60, DEC MicroPDP-11/73
Synthesizers: Roland JX-10/MT-32/D-10, Oberheim Matrix-6, Yamaha DX7/FB-01, Korg MS-20 Mini, Ensoniq Mirage/SQ-80, Sequential Circuits Prophet-600, Hohner String Performer

"\'Legacy code\' often differs from its suggested alternative by actually working and scaling." - Bjarne Stroustrup
 

Offline paul1981

Re: AmiWolf AGA - new Wolfenstein 3D Port
« Reply #61 on: September 12, 2013, 09:31:21 PM »
Quote from: commodorejohn;747322
So I'm running an A1200 with a DKB 1240 (68030 @ 50MHz) and 16MB RAM with ClassicWB, and AmiWolf starts up fine and goes through the menu without issue - but when I start a new game, it displays the "Get Psyched!" loading screen, then goes black and seems to just hang; I left it sit for about fifteen minutes without it getting to the level...any ideas what I should try in order to pin this down? (I can't run it without the accelerator, as that has all the non-chip RAM - and it's not an unstable board anyway...)

Also, why's it run in interlaced mode? Wolfenstein's 320x200 is already supported by the Amiga...

Are you running any mode promotion software? It's all I can think of at this time - although I haven't tried this port myself yet.
 

Offline NovaCoder

Re: AmiWolf AGA - new Wolfenstein 3D Port
« Reply #62 on: September 12, 2013, 09:32:29 PM »
Quote from: commodorejohn;747755
No errorlog, I'm afraid. I tried running it with 32MB as well, same result. (I'd be kind of astonished if a game that required 528KB on DOS required anything like even 16MB on the Amiga - even with the 4MB "MIDI instruments" file...)


It's not a lack of memory because someone managed to get it running with only 6MB, maybe it's a patch???
Life begins at 100 MIPS!


Nice Ports on AmiNet!
 

Offline paul1981

Re: AmiWolf AGA - new Wolfenstein 3D Port
« Reply #63 on: September 12, 2013, 09:34:17 PM »
Quote from: NovaCoder;747769
It's not a lack of memory because someone managed to get it running with only 6MB, maybe it's a patch???

Does it play well with FBlit?
 

Offline Oldsmobile_Mike

Re: AmiWolf AGA - new Wolfenstein 3D Port
« Reply #64 on: September 12, 2013, 09:34:48 PM »
Maybe memory fragmentation?  TLSFMem?
Amiga 500: 2MB Chip|16MB Fast|30MHz 68030+68882|3.9|Indivision ECS|GVP A500HD+|Mechware card reader + 8GB CF|Cocolino|SCSI DVD-RAM
Amiga 2000: 2MB Chip|136MB Fast|50MHz 68060|3.9|Indivision ECS + GVP Spectrum|Mechware card reader + 8GB CF|AD516|X-Surf 100|RapidRoad|Cocolino|SCSI CD-RW
 Amiga videos and other misc. stuff at https://www.youtube.com/CompTechMike/videos
 

Offline commodorejohn

Re: AmiWolf AGA - new Wolfenstein 3D Port
« Reply #65 on: September 12, 2013, 09:42:10 PM »
Quote from: paul1981;747768
Are you running any mode promotion software? It's all I can think of at this time - although I haven't tried this port myself yet.
I don't know - does ClassicWB come with any? I've never quite understood how this works...

Quote from: Oldsmobile_Mike;747771
Maybe memory fragmentation?  TLSFMem?
I doubt this is the case, since I've run it multiple times from a fresh boot (on a configuration that takes only a couple MB of the 16MB total fast RAM) and it's done this consistently.
Computers: Amiga 1200, DEC VAXStation 4000/60, DEC MicroPDP-11/73
Synthesizers: Roland JX-10/MT-32/D-10, Oberheim Matrix-6, Yamaha DX7/FB-01, Korg MS-20 Mini, Ensoniq Mirage/SQ-80, Sequential Circuits Prophet-600, Hohner String Performer

"\'Legacy code\' often differs from its suggested alternative by actually working and scaling." - Bjarne Stroustrup
 

Offline paul1981

Re: AmiWolf AGA - new Wolfenstein 3D Port
« Reply #66 on: September 12, 2013, 09:44:17 PM »
Quote from: commodorejohn;747755
No errorlog, I'm afraid. I tried running it with 32MB as well, same result. (I'd be kind of astonished if a game that required 528KB on DOS required anything like even 16MB on the Amiga - even with the 4MB "MIDI instruments" file...)

Have you tried running Snoopdos yet? I'd turn all the monitor switches on and have a good look at the output created.
Are you using a custom rom with custom graphics.library or anything?
 

Offline Oldsmobile_Mike

Re: AmiWolf AGA - new Wolfenstein 3D Port
« Reply #67 on: September 12, 2013, 09:46:36 PM »
Is it possible to boot with no startup sequence and try to run it then?  Sorry, just tossing ideas out there now!
Amiga 500: 2MB Chip|16MB Fast|30MHz 68030+68882|3.9|Indivision ECS|GVP A500HD+|Mechware card reader + 8GB CF|Cocolino|SCSI DVD-RAM
Amiga 2000: 2MB Chip|136MB Fast|50MHz 68060|3.9|Indivision ECS + GVP Spectrum|Mechware card reader + 8GB CF|AD516|X-Surf 100|RapidRoad|Cocolino|SCSI CD-RW
 Amiga videos and other misc. stuff at https://www.youtube.com/CompTechMike/videos
 

Offline paul1981

Re: AmiWolf AGA - new Wolfenstein 3D Port
« Reply #68 on: September 12, 2013, 09:53:58 PM »
Quote from: Oldsmobile_Mike;747774
Is it possible to boot with no startup sequence and try to run it then?  Sorry, just tossing ideas out there now!

Run setpatch first though or AGA won't be activated and it'll probably black screen or something. ;)
Unless AmiWolf bangs the hardware directly that is... but I don't think it does if it multitasks.
« Last Edit: September 12, 2013, 10:27:20 PM by paul1981 »
 

Offline commodorejohn

Re: AmiWolf AGA - new Wolfenstein 3D Port
« Reply #69 on: September 12, 2013, 10:03:02 PM »
Quote from: paul1981;747773
Have you tried running Snoopdos yet? I'd turn all the monitor switches on and have a good look at the output created.
Are you using a custom rom with custom graphics.library or anything?
I'll see if I can give that a try. No custom ROM or anything fancy, just a vanilla ClassicWB install with FBlit enabled.
Computers: Amiga 1200, DEC VAXStation 4000/60, DEC MicroPDP-11/73
Synthesizers: Roland JX-10/MT-32/D-10, Oberheim Matrix-6, Yamaha DX7/FB-01, Korg MS-20 Mini, Ensoniq Mirage/SQ-80, Sequential Circuits Prophet-600, Hohner String Performer

"\'Legacy code\' often differs from its suggested alternative by actually working and scaling." - Bjarne Stroustrup
 

Offline NovaCoder

Re: AmiWolf AGA - new Wolfenstein 3D Port
« Reply #70 on: September 12, 2013, 10:04:38 PM »
If you are running ClassicWB make sure you disable CyberBugFix, it's a horrible hack which is known to cause issues with my ports.

With the newer versions of ClassicWB it's an optional install.
« Last Edit: September 12, 2013, 11:47:04 PM by NovaCoder »
Life begins at 100 MIPS!


Nice Ports on AmiNet!
 

Offline NovaCoder

Re: AmiWolf AGA - new Wolfenstein 3D Port
« Reply #71 on: September 14, 2013, 07:08:29 AM »
It's on AmiNet now :)
Life begins at 100 MIPS!


Nice Ports on AmiNet!
 

Offline commodorejohn

Re: AmiWolf AGA - new Wolfenstein 3D Port
« Reply #72 on: September 14, 2013, 08:03:20 AM »
Quote from: NovaCoder;747779
If you are running ClassicWB make sure you disable CyberBugFix, it's a horrible hack which is known to cause issues with my ports.
I'll look into that. Shouldn't need it anyway as it's a plain AGA machine...
Computers: Amiga 1200, DEC VAXStation 4000/60, DEC MicroPDP-11/73
Synthesizers: Roland JX-10/MT-32/D-10, Oberheim Matrix-6, Yamaha DX7/FB-01, Korg MS-20 Mini, Ensoniq Mirage/SQ-80, Sequential Circuits Prophet-600, Hohner String Performer

"\'Legacy code\' often differs from its suggested alternative by actually working and scaling." - Bjarne Stroustrup
 

Offline skolman

Re: AmiWolf AGA - new Wolfenstein 3D Port
« Reply #73 on: September 15, 2013, 12:10:31 AM »
A1200 BlizzardPPC BVision Lan/WiFi FastATA Gold,
EFIKA 5K2 R9250 MorphOS +Amiga Workbench
https://youtu.be/mjsGVkDjBOc
 

Offline NovaCoder

Re: AmiWolf AGA - new Wolfenstein 3D Port
« Reply #74 on: September 15, 2013, 04:27:45 AM »
Quote from: skolman;748010
CyberBugfiX is for http://aminet.net/package/driver/video/CGX-AGA


Another user has confirmed that CGX-AGA is not compatible with AmiWolf.
Life begins at 100 MIPS!


Nice Ports on AmiNet!