Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: What's up with USB thumb drives on OS4?  (Read 3609 times)

0 Members and 1 Guest are viewing this topic.

Offline spihunter

What's up with USB thumb drives on OS4?
« on: March 21, 2011, 02:35:08 PM »
...
« Last Edit: April 03, 2011, 01:35:01 AM by spihunter »
 

Offline jorkany

Re: What's up with USB thumb drives on OS4?
« Reply #1 on: March 21, 2011, 02:40:46 PM »
That's odd, I've heard that USB works fine under OS4. So well in fact that there isn't even any need for USB2.

At least that is what I have read in various forums.
 

Offline spihunter

Re: What's up with USB thumb drives on OS4?
« Reply #2 on: March 21, 2011, 02:44:09 PM »
...
« Last Edit: April 03, 2011, 01:35:12 AM by spihunter »
 

Offline ferrellsl

Re: What's up with USB thumb drives on OS4?
« Reply #3 on: March 21, 2011, 02:44:57 PM »
My experience with USB support under OS4 has been pretty terrible.  Most USB sticks aren't recognized at all and other sticks get scrambled or have read/write errors.  Not to mention that there's no USB2.0 support.  I'm using a PegII/ODW which has USB2.0 ports and it would be nice if OS4 supported them but I doubt I'll ever see it.  Hyperion is focusing on the the X1000......
 

Offline spihunter

Re: What's up with USB thumb drives on OS4?
« Reply #4 on: March 21, 2011, 04:36:34 PM »
Well, Now it won't read the drive anymore. It's giving an "unable to mount device" error everytime I try it. This sucks! None of the 6 different USB drive here work.......

Can anyone get Octamed and the Maestrix running on MorphOS so I can finally be happy! ;)
 

Offline Varthall

Re: What's up with USB thumb drives on OS4?
« Reply #5 on: March 21, 2011, 04:47:05 PM »
Quote from: jorkany;623467
That's odd, I've heard that USB works fine under OS4. So well in fact that there isn't even any need for USB2.

At least that is what I have read in various forums.

The quality of the implementation of a protocol has nothing to do with the need (or not) of support of another protocol.

Varthall
AmigaOne XE - AmigaOS 4.1 - Freescale 7457 1GHz - 1GB ram
MPlayer for OS4: https://sourceforge.net/projects/mplayer-amigaos/
 

Offline jorkany

Re: What's up with USB thumb drives on OS4?
« Reply #6 on: March 21, 2011, 05:01:52 PM »
Quote from: Varthall;623484
The quality of the implementation of a protocol has nothing to do with the need (or not) of support of another protocol.

Varthall

I know, it's just a convenient excuse for some in the OS4 community as to why USB2 isn't yet implemented.

By the way:
http://www.amiga.org/forums/showthread.php?p=562228#post562228
"The OS4 USB drivers has been working for years!"
 

Offline Gilloo

Re: What's up with USB thumb drives on OS4?
« Reply #7 on: March 21, 2011, 05:02:42 PM »
The bulk only with transparent scsi commands (8,5,80) is easy to implement, after having understood what to do with 2 endpoints (in and out) and the 3 phases Command Block Wrapper (CBW), DATA, Command Status Wrapper (CSW) and has nothing to see with usb 2.0 or not.
Perhaps massstorage on Sirion is mixed with very old CBI implementation, which is a horror to code, maintain and fix.

I'ts bad to see that OS4 is not reliable.
FAT32 4GB keys are usable on my A2000 68000/Highway/Subway Workbench 3.1 with fat95.
Big shame.
 

Offline nicholas

Re: What's up with USB thumb drives on OS4?
« Reply #8 on: March 21, 2011, 05:19:34 PM »
Quote from: Gilloo;623486
The bulk only with transparent scsi commands (8,5,80) is easy to implement, after having understood what to do with 2 endpoints (in and out) and the 3 phases Command Block Wrapper (CBW), DATA, Command Status Wrapper (CSW) and has nothing to see with usb 2.0 or not.
Perhaps massstorage on Sirion is mixed with very old CBI implementation, which is a horror to code, maintain and fix.

I'ts bad to see that OS4 is not reliable.
FAT32 4GB keys are usable on my A2000 68000/Highway/Subway Workbench 3.1 with fat95.
Big shame.


They are also usable on a 7MHz A500 with 512KB of RAM and a Workbench 1.x too!

http://www.amiga.org/forums/showthread.php?t=57010
“Een rezhim-i eshghalgar-i Quds bayad az sahneh-i ruzgar mahv shaved.” - Imam Ayatollah Sayyed  Ruhollah Khomeini
 

Offline lsmart

Re: What's up with USB thumb drives on OS4?
« Reply #9 on: March 21, 2011, 05:38:46 PM »
Are you sure you used plain VFAT16 to format them?

In my experience (SAM440EP Flex with OS4.1u2) almost all of the USB-thumbdrives I tried worked flawlessly. Two however refused to show up on Workbench. I have noticed that you can corrupt the filesystem, if you remove the stick too early when writing data.

The progress bar on Workbench is apparently no good indication. I have grown into the habit of waiting an additional minute before removing the thumbdrive and had no data loss since.
 

Offline Duce

  • Off to greener pastures
  • Hero Member
  • *****
  • Join Date: Jul 2009
  • Posts: 1699
  • Total likes: 0
    • http://amigabbs.blogspot.com/
Re: What's up with USB thumb drives on OS4?
« Reply #10 on: March 21, 2011, 05:49:04 PM »
Never had a single issue with USB sticks on my SAM, running 4.1.
 

Offline nicholas

Re: What's up with USB thumb drives on OS4?
« Reply #11 on: March 21, 2011, 05:54:22 PM »
Quote from: spihunter;623465
Hey Folks,

I recently got my hands on a G3 Amigaone with OS 4.1

I can't seem to get it to read any of the 4 different types of FAT formatted
USB sticks I have here. They all come up as Unformatted or nothing happens at all?

Is there something I need to install to get it to read these kind of drives?


Just a thought, has your A1 had the hardware fixes applied to it to make the USB ports work correctly?
“Een rezhim-i eshghalgar-i Quds bayad az sahneh-i ruzgar mahv shaved.” - Imam Ayatollah Sayyed  Ruhollah Khomeini
 

Offline spihunter

Re: What's up with USB thumb drives on OS4?
« Reply #12 on: March 21, 2011, 06:55:57 PM »
...
« Last Edit: April 03, 2011, 01:35:24 AM by spihunter »
 

Offline spihunter

Re: What's up with USB thumb drives on OS4?
« Reply #13 on: March 21, 2011, 06:58:07 PM »
....
« Last Edit: April 03, 2011, 01:35:33 AM by spihunter »
 

Offline -BobW-

Re: What's up with USB thumb drives on OS4?
« Reply #14 on: March 21, 2011, 07:22:49 PM »
"I have know idea?. I bought it second hand. It's an original 600mhz G3 AmigaOne. I'll have to read up on what the fixes were."

That sounds like one of the old AmigaOne SE's.  They are pretty much a lost cause as far as USB goes.
Amiga 500 GVP A530 Accel + SCSI2SD + 8 MB RAM and OS 2.04
Amiga 1200 GVP \\\'030 Accel + 32 MB RAM and OS 3.9 BB3
Amiga 4000 Cybervision 64/3D Mk-II + Warp Engine 4040 128 MB RAM and OS 3.9 BB3
Micro A1 866 Mhz and AmigaOS 4.1
PowerMac G4 1.4 Ghz and MorphOS 3.9
Mac Mini G4 1.5 Ghz and MorphOS 3.9