Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: amiga startup  (Read 1776 times)

0 Members and 1 Guest are viewing this topic.

Offline jono51

amiga startup
« on: January 07, 2011, 10:08:02 AM »
hi everyone am new to this forum so please be patient.The problem i have is with my amiga 500+.I havent used it for years and the other day i decided to relive my youth.I've set it all up but when i switch on the power light just flashes and nothing else happens.The floppy spins but only about one revolution then stops.Have tried putting workbench in but still nothing.I just get a blank screen even when i try to retune tv
 

Offline Franko

Re: amiga startup
« Reply #1 on: January 07, 2011, 10:12:47 AM »
Without putting any disk in the drive and switching on your Amiga are you getting the white Amiga insert disk screen showing up (A picture of a hand holding a disk if I recall correctly, it's been many years since I've seen one...) :)
« Last Edit: January 09, 2011, 08:53:40 AM by Franko »
 

Offline vidarh

Re: amiga startup
« Reply #2 on: January 07, 2011, 10:55:12 AM »
What colour is the screen? The colour during startup gives diagnostic information.
 

Offline jono51

Re: amiga startup
« Reply #3 on: January 07, 2011, 09:02:05 PM »
no not getting any screen images at all as far as i can tell the screen is just a bluish colour.The power light has a regular flash.It flashes 10 times and on the 11th flash it stays on a little longer.Is it knackered
 

Offline InTheSand

Re: amiga startup
« Reply #4 on: January 07, 2011, 09:44:54 PM »
 

Offline Zac67

Re: amiga startup
« Reply #5 on: January 07, 2011, 10:01:09 PM »
Battery of RAM expansion still present? It may have leaked and damaged the chipram.
 

Offline jono51

Re: amiga startup
« Reply #6 on: January 08, 2011, 10:26:06 PM »
have opened up amiga today and checked onboard battery guess what the damn thing has leaked on motherboard.Is this the end or what can i do to get my amiga up and running again
 

Offline kickstart

Re: amiga startup
« Reply #7 on: January 09, 2011, 12:58:19 AM »
Maybe its not the end of your amiga, some patience and clean it with isopropyl alcohol by example.
a1200 060
 

Offline runequester

  • It\'s Amiga time!
  • Hero Member
  • *****
  • Join Date: Oct 2009
  • Posts: 3695
  • Total likes: 0
Re: amiga startup
« Reply #8 on: January 09, 2011, 01:07:46 AM »
its possible to gently clean it off. Be careful though, as the stuff isn't great for your skin.

Getting another 500+ is likely to be tricky, but 500's and 600's do tend to come for sale often.

Good luck!