Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Hollywood MAL AMIStore App Store A600 Memory

AuthorTopic: Amikit-latest.sh - Mac OSX PPC / X86 & Linux x86 = Binary & any other *nix = Source  (Read 4463 times)

0 Members and 1 Guest are viewing this topic.

Offline mike-

For the finalth time...

Amikit-latest.sh v0.10 works on OSX ppc & i386, it also works on linux.  It will always install the latest version of amikit. But for linux x86/64 i recommend using Tom Newsom´s linux installer found on http://amikit.amiga.sk/downloads.htm if that is possible.  

It should work on other systems also given that you satisfy euae´s deps. it will try to compile and do pretty much exactly as with the binary method. i havent added the checks for any dependencies, but i figure if your going to compile it, you know enough to do this yourself.

http://www.sendspace.com/file/bj6670
Amikit-nix v0.10
*Fixed oddities.
*Added option to get Boing Bag 1 and 2. Remember to set up AmiKit first*
(I had to do this due to unknown issues with e-uae and the bb-1&2 installer on OSX atleast...)
*Uninstall works better.
*Ready to be picked apart and used in a final OSX package.

Usage: sh amikit-latest.sh
Follow the cursor...

lha binaries for osx ppc & i386 & linux x86 are now on aminet, so the scripts retrieves those from there unless lha is installed in /usr/bin/ or /bin/.  

Amikit needs to be fully installed before you can go trough the BB1-2 install using this method, you can choose configure again at a later time without going trough the full install of course, and set this up. By that i mean, have your AmigaOS3.9 3.5 XL or whatever in the cdrom and launching the emulator going torugh the amikit installation from within uae.

Happy kittin
« Last Edit: February 17, 2010, 04:09:03 PM by mike- »
C= Amiga Addict & Dendrophiliac
,,,
(Oo)
⎛☮ໄ
ﮑὠՀ
 

Offline jorkany

Re: Amikit OSX - Testers needed!
« Reply #1 on: December 02, 2009, 03:11:31 PM »
Quote from: mike-;532249
I´d also like to know the output of uname and uname -p on osx x86 just to be sure.


uname: Darwin

uname -p: i386
 

Offline mike-

Re: Amikit OSX - Testers needed!
« Reply #2 on: December 02, 2009, 03:19:49 PM »
@jorkany

Thank you.
That i guess is a intel core duo. not core 2 duo?

I just finished 15x. In the middle of running it here but it looks like it should work, i´ve removed some cleanup commands though incase something goes apeshit. ( in both scripts)

Scratch that, it died on me
« Last Edit: December 02, 2009, 03:26:42 PM by mike- »
C= Amiga Addict & Dendrophiliac
,,,
(Oo)
⎛☮ໄ
ﮑὠՀ
 

Offline jorkany

Re: Amikit OSX - Testers needed!
« Reply #3 on: December 02, 2009, 04:24:00 PM »
Quote from: mike-;532255
That i guess is a intel core duo. not core 2 duo?

My core duo MacBook and Xeon MacPro return the same results. I don't have a core 2 duo to test with.
 

Offline mike-

Re: Amikit OSX - Testers needed!
« Reply #4 on: December 02, 2009, 04:54:44 PM »
Ok, thanks, im betting that would say x86_64 or something like that. I found some errors etc in the script (1.5.x version)  .


However i have no idea what to do about these errors.

checkdir error:  cannot create Utilities/ZoneXplorer/Modules/Rational/InvNwt?,+C_under_M
                 unable to process Utilities/ZoneXplorer/Modules/Rational/InvNwt?,+C_under_M/Radar.zone.
checkdir error:  cannot create Utilities/ZoneXplorer/Modules/Rational/InvNwt?,+C_under_M
                 unable to process Utilities/ZoneXplorer/Modules/Rational/InvNwt?,+C_under_M/HalfAWay.zone.
checkdir error:  cannot create Utilities/ZoneXplorer/Modules/Rational/InvNwt?,+C_under_M
                 unable to process Utilities/ZoneXplorer/Modules/Rational/InvNwt?,+C_under_M/Default.zone.
checkdir error:  cannot create Utilities/ZoneXplorer/Modules/Rational/InvNwt?,+C_under_M
                 unable to process Utilities/ZoneXplorer/Modules/Rational/InvNwt?,+C_under_M/03Into01.zone.
checkdir error:  cannot create Utilities/ZoneXplorer/Modules/Rational/InvNwt?,+C_under_M
                 unable to process Utilities/ZoneXplorer/Modules/Rational/InvNwt?,+C_under_M/02Into00.zone.
checkdir error:  cannot create Utilities/ZoneXplorer/Modules/Rational/InvNwt?,+C_under_M
                 unable to process Utilities/ZoneXplorer/Modules/Rational/InvNwt?,+C_under_M/01Sponge.zone.
checkdir error:  cannot create Utilities/ZoneXplorer/Modules/Rational/InvNwt?,+C_under_M
                 unable to process Utilities/ZoneXplorer/Modules/Rational/InvNwt?,+C_under_M/00.zone.
checkdir error:  cannot create Utilities/ZoneXplorer/Modules/Rational/InvNwt?,+C_over_M
« Last Edit: December 03, 2009, 03:25:45 AM by mike- »
C= Amiga Addict & Dendrophiliac
,,,
(Oo)
⎛☮ໄ
ﮑὠՀ
 

Offline pan1k

Re: Amikit OSX - Testers needed!
« Reply #5 on: December 02, 2009, 05:38:44 PM »
I'll check this out.. I've got an intel imac that i'm trying to setup winuae + hitoro right now... i'll let you know!
A4K: \\\'060, Cyberstorm MKIII Cybervision 64/3D w/ Scandoubler, Buddha Flash XSurf, MP3@64, A4K: \\\'040, Toaster, Y/C, A1200: Apollo \\\'040, A1200 GVP \'030, A1200: Stock, A2000: 68K, Trump SCSI, Supra 8Mb, and Toaster 4K, A2500: \\\'030, GVP SCSI, Supra 8MB x2, Video Toaster, CD32, Minimig, Efika and Hopefully an A4000T soon!
 

Offline mousehouse

Re: Amikit OSX - Testers needed!
« Reply #6 on: December 02, 2009, 05:43:19 PM »
My update MBP, core2duo running OSX 10.6.2 gives,

uname -a:
Darwin laptop.local 10.2.0 Darwin Kernel Version 10.2.0: Tue Nov  3 10:37:10 PST 2009; root:xnu-1486.2.11~1/RELEASE_I386 i386

uname -p:
i386

I guess they just use 'i386' and don't differentiate between 32 and 64 bit here...
A3000T
 

Offline mike-

Re: Amikit OSX - Testers needed!
« Reply #7 on: December 02, 2009, 05:57:23 PM »
Thanks mouse, then i think i have eveything i need to finish everything except for that those charter errors on those folders and files.

Pan1k,
Cool, im just about ready with the next step of the script, been adding hitoro now, both e-uae and hi-toro now copies themselves to Applications/*-akit.app ( would be an awful shame to overwrite someones working uae hence the +akit*)
C= Amiga Addict & Dendrophiliac
,,,
(Oo)
⎛☮ໄ
ﮑὠՀ
 

Offline mike-

Re: Amikit OSX - Testers needed!
« Reply #8 on: December 02, 2009, 06:43:27 PM »
One last thing that didnt make it
echo "The amikit drive has to be named AK0: with name AmiKit:"
echo "The cdrom is just CD0:"

TODO:
Figure out if the osx gui tool handles the screwed folder and file names correctly.
Invent a gui around this. ( Some day )
« Last Edit: December 03, 2009, 03:13:44 AM by mike- »
C= Amiga Addict & Dendrophiliac
,,,
(Oo)
⎛☮ໄ
ﮑὠՀ
 

Offline mike-

Re: Amikit OSX - Testers needed!
« Reply #9 on: December 03, 2009, 03:13:15 AM »
Fixed the extraction issue using a different unzip method.

This should be the final one for now. ( and last script i ever write )

Edit: old url out
« Last Edit: December 05, 2009, 06:17:14 PM by mike- »
C= Amiga Addict & Dendrophiliac
,,,
(Oo)
⎛☮ໄ
ﮑὠՀ
 

Offline mike-

Re: Amikit OSX - Testers needed!
« Reply #10 on: December 03, 2009, 08:19:23 AM »
EDIT:
nvm.

The script works, the version in the post is close to what the finished one will do/does. ( only some slight cosmetic changes and little fixtures )
« Last Edit: December 03, 2009, 09:06:38 AM by mike- »
C= Amiga Addict & Dendrophiliac
,,,
(Oo)
⎛☮ໄ
ﮑὠՀ
 

Offline mike-

Re: Amikit OSX - Testers needed!
« Reply #11 on: December 03, 2009, 12:45:46 PM »
and thats the final one i believe.
It also needs to be tested on various linux distributions (binary x86) and if it compiles on various   *nix platforms, just be sure the dependencies are around, i havent added checks for that and if it breaks i think it will try to continue and screw up, and for non linux platforms, i´d recommend using SDL ..


Edit: old url out
« Last Edit: December 05, 2009, 06:17:38 PM by mike- »
C= Amiga Addict & Dendrophiliac
,,,
(Oo)
⎛☮ໄ
ﮑὠՀ
 

Offline mike-

Re: Amikit OSX - Testers needed!
« Reply #12 on: December 05, 2009, 06:16:35 PM »
thats a wrap, stuffing it on a floppy and throwing it out the window now.
see first post
C= Amiga Addict & Dendrophiliac
,,,
(Oo)
⎛☮ໄ
ﮑὠՀ
 

Offline metalmac

Re: Amikit OSX - final
« Reply #13 on: December 05, 2009, 07:27:56 PM »
Quote from: mike-;532249
EDIT:

Im going to call it for this time.
Amikit nix v0.05 works on OSX ppc & i386, it also works on linux but i recommend using Tom Newsom´s linux installer found on http://amikit.amiga.sk/downloads.htm as it might have configuration changes not included here.

It should work on other systems also given that you satisfy euae´s deps. it will try to compile and do pretty much exactly as with the binary method. i havent added the checks for any dependencies, but i figure if your going to compile it, you know enough to get the archive and make your own, anyway.

http://www.sendspace.com/file/vjz85u

Happy kittin

Hi!

Can I use this to install AmiKit and UAE on my macbook?
How do I do it?
 

Offline mike-

Amikit-latest.sh
« Reply #14 on: December 06, 2009, 03:54:03 AM »
It certainly should, i´ve not tested it myself on i386, but its been reported working.

You just "sh amikit-nix.sh" in a terminal, and hit 1.

Here it is , running under something like 50% load load, still trying to find better configs. gl-rendering definitely speeds things up, just as the manual says, i could use some help tweaking though.


Tweaking the frameskip and turning on Immediate blitters helps a little.
« Last Edit: December 08, 2009, 06:45:44 AM by mike- »
C= Amiga Addict & Dendrophiliac
,,,
(Oo)
⎛☮ໄ
ﮑὠՀ