Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A600 Memory

AuthorTopic: How to create a fast (but stable) OS3.9 AGA setup  (Read 24388 times)

0 Members and 1 Guest are viewing this topic.

Offline darkage

Re: How to create a fast (but stable) OS3.9 AGA setup
« Reply #75 on: December 13, 2012, 11:30:06 PM »
I guess Peters Peter K's icon.library is available somewhere over at EAB.. Just had a quick google now..    Looks pretty sexy but still blends in quite nicely with the overall desktop!
 

Offline kickstart

Re: How to create a fast (but stable) OS3.9 AGA setup
« Reply #76 on: December 14, 2012, 05:44:02 AM »
@all

Sorry but... cybergrafx on AGA?

@novacoder

nice wb
a1200 060
 

Offline Crumb

Re: How to create a fast (but stable) OS3.9 AGA setup
« Reply #77 on: December 14, 2012, 09:33:06 AM »
Quote from: kickstart;718988
@all

Sorry but... cybergrafx on AGA?


Yes, there's a CGX driver for AGA, although I don't think it improves speed much compared to the typical patches. When I heard about it I thought "kewl! I'll have a Ham8 WB and will be able to run some apps in CGX 15bit screens!" but it doesn't have R5G5B5->ham8 support :_( Ham8 screens were slow in Fusion but quite cool.

The best thing to avoid slowing down your miggies is using screenmodes that don't use too many DMA channels: e.g. AGA 640x480 flicker free in more than 16 colours will use too many dma channels and will slow down chipmem access (no matter how many patches you use to make the problem less noticeable, the problem will remain there), AGA SuperHiRes screenmodes act like those productivity screenmodes, more than 16colours will slow down. 15Khz HiRes on AGA is no problem regardless of the number of colours (blitter will need more time to blit due to the higher number of bitplanes but cpu will be able to access chipram at full speed).

With OCS/ECS anything HiRes in more than 4 colours will slow down your miggy, MagicWB makes little sense in OCS/ECS machines. If I could choose an iconset I would use 1.x-style icons for OCS/ECS machines since the icons looked great (I love the white rabbit jumping over the turtle). For apps I would use separate screens with normal 2.x/3.x colours.
The only spanish amiga news web page/club: Club de Usuarios de Amiga de Zaragoza (CUAZ)
 

Offline magnetic

Re: How to create a fast (but stable) OS3.9 AGA setup
« Reply #78 on: December 15, 2012, 12:05:24 AM »
Crumb

Interesting post. I disagree with the part about magic workbench on ocs/ecs. MB works very well for me with lower speced machines..
What about the new MK2 modes like Superplus and those? How fast is chipmem access?

And the most important question why do you have an avatar with Satanic imagery? Thats quite offensive and i'm sure against the TOS
bPlan Pegasos2 G4@1ghz
Quad Boot:Reg. MorphOS | OS4.1 U4 |Ubuntu GNU-Linux | MacOS X

Amiga 2000 Rom Switcher w/ 3.1 + 1.3 | HardFrame SCSI | CBM Ram board| A Squared LIVE! 2000 | Vlab Motion | Firecracker 24 gfx

Commodore CDTV: 68010 | ECS | 9mb Ram | SCSI -TV | 3.9 Rom | Developer EPROMs