Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Hollywood MAL AMIStore App Store A600 Memory

AuthorTopic: Amiga.org - Ibrowse and Aweb support sucks  (Read 5341 times)

0 Members and 1 Guest are viewing this topic.

Offline Tumbleweed

Re: Amiga.org - Ibrowse and Aweb support sucks
« Reply #15 on: January 07, 2010, 02:03:56 PM »
I pretty much use NetSurf as my primamry browser on my A4000D now since A.Org moved to the current set-up.  NetSurf isnt perfect but its still being developed and hopefully it'll get better over time.

Weed.
A4000D, Cyberstorm MKII 060, CV3D, Scandoubler, Deneb2.0; A3000D 040, CV64; A3000T, PicassoII, Z3 Fastlane; A2000D, 040, PicassoII; A1200, Blizzard 030 MKIV.
 

Offline Fingers

Re: Amiga.org - Ibrowse and Aweb support sucks
« Reply #16 on: January 07, 2010, 02:41:36 PM »
Has anyone tried it on a machine with lesser specs than those listed?

I'd be interested to know if it works at all "under-spec" (however badly), or if the software simply won't install/work based on hardware requirements.

PZ.
 

Offline 0amigan0

Re: Amiga.org - Ibrowse and Aweb support sucks
« Reply #17 on: January 07, 2010, 03:05:20 PM »
Quote from: Fingers;536884
Has anyone tried it on a machine with lesser specs than those listed?

I'd be interested to know if it works at all "under-spec" (however badly), or if the software simply won't install/work based on hardware requirements.

PZ.


On RiscOS it requires at least a mere 16 MB Ram.
On amiga it's more heavyweight because of the use of ixemul library and because of the fact that it is not native.
 

Offline Tumbleweed

Re: Amiga.org - Ibrowse and Aweb support sucks
« Reply #18 on: January 07, 2010, 03:28:53 PM »
Quote from: Fingers;536884
Has anyone tried it on a machine with lesser specs than those listed?

I'd be interested to know if it works at all "under-spec" (however badly), or if the software simply won't install/work based on hardware requirements.

PZ.


Cool, but maybe not suitable for everyone due to...quote:

"Requirements:

* AmigaOS 3.x (no worries for almost all users)
* Picasso96 / CGX graphic card (problem for some)
* 128 MB Ram (problem for many)
* Equivalent of 100 Mhz 060 Cpu (problem for many, many) "

I'm running it on a 50mMhz  68060, but admittedly with 128MB and a gfx card. NetSurf is reasonable considering the hardware and what its doing in terms of rendering CSS. A native port would be much fastr though.

Weed.
A4000D, Cyberstorm MKII 060, CV3D, Scandoubler, Deneb2.0; A3000D 040, CV64; A3000T, PicassoII, Z3 Fastlane; A2000D, 040, PicassoII; A1200, Blizzard 030 MKIV.
 

Offline Pyromania

Re: Amiga.org - Ibrowse and Aweb support sucks
« Reply #19 on: January 07, 2010, 08:00:25 PM »
Amiga.org will not be changing to accommodate outdated web browsers that don't support CSS properly. Even the Greeks back in Plato's time had a more modern web browser then some old Amiga browsers. The problem lies with the developers of those browsers not Amiga.org. As many have already stated there are other browsers available that are more modern.

Trying to kluge something together for an outdated browser would be a disservice to the Amiga.org community and a waste of time. If you want your favorite Amiga browser to support modern websites then contact it's developer and have them update it. If they don't updated their code you have gotten to the source of the problem. Support developers that are making progress and releasing new, up to date applications.
« Last Edit: January 07, 2010, 08:06:44 PM by Pyromania »
 

Offline Matt_H

Re: Amiga.org - Ibrowse and Aweb support sucks
« Reply #20 on: January 07, 2010, 10:58:03 PM »
Quote from: Pyromania;536968
Amiga.org will not be changing to accommodate outdated web browsers that don't support CSS properly. Even the Greeks back in Plato's time had a more modern web browser then some old Amiga browsers. The problem lies with the developers of those browsers not Amiga.org. As many have already stated there are other browsers available that are more modern.

Trying to kluge something together for an outdated browser would be a disservice to the Amiga.org community and a waste of time. If you want your favorite Amiga browser to support modern websites then contact it's developer and have them update it. If they don't updated their code you have gotten to the source of the problem. Support developers that are making progress and releasing new, up to date applications.


And I'll add that Amiga.org does actually "work" with IBrowse, it's just not pretty.
 

Offline DyLucke

Re: Amiga.org - Ibrowse and Aweb support sucks
« Reply #21 on: January 08, 2010, 09:06:40 AM »
I'll use an Amiga browser whenever i'll be able to install MorphOS on my MacMini, i want to preserve the OSX partition and i didn't find the way to do it for now. (i must be dumb).

However i'm quite busy with other projects by now, C64 with 1541 ultimate, Atari XE with SIO2SD, and Atari STe with UltraSatan, plus... of course sorting all my Amiga stuff gathered along years and years to be installed on one of my A1200's with 40gb HDD... I have a lot of work, and Mac-Morphos is at the end of the row for now. But whenever i'll have it finished, i'm sure i'll drop the farging PC to a mere "ocassional use". I'll do almost all my routinary stuff with MOS on the mini.
The only way for evil to triumph is for good men to do nothing.
Edmund Burke.

A1200 Blizzard 060/66 64MB FastRam + 40GB HDD + Subway USB.
A1200 Apollo   040/33 32MB FastRam + 40GB HDD.
CD32!!!!
A500 4MB + 2GB IDE-CF adapter.
Mac Mini G4 1,5ghz  waiting for MorphOS.
C64, C64C, C64G, C128... 1541U-II.
Atari STe... SatanDisk, Atari 130XE... SDNuxx
 

Offline chris

Re: Amiga.org - Ibrowse and Aweb support sucks
« Reply #22 on: January 08, 2010, 11:09:23 PM »
Quote from: arnljot;536882
Netsurf GUI needs an intuition port if possible, also WarpOS would be nice.


The OS4 version has a Reaction GUI - it shouldn't need much tweaking for OS3.9.  There are other code parts which are more OS4 specific and will require retro-fitting.

Somebody who has the time and knowledge to look through it probably wouldn't have much trouble back-porting it to OS3.9.

Quote
But it's still a RAM eater, so it wouldn't help me much.


There's a caching bug in the current versions - a fix is being worked on.
"Miracles we do at once, the impossible takes a little longer" - AJS on Hyperion
Avatar picture is Tabitha by Eric W Schwartz
 

Offline arnljot

Re: Amiga.org - Ibrowse and Aweb support sucks
« Reply #23 on: January 08, 2010, 11:17:56 PM »
@chris

Glad to hear it. Wish I could help out. But I have no clue about Amiga APIs
A posting a day keeps the sanity away...
http://www.arnljot.com
 

Offline recidivist

Re: Amiga.org - Ibrowse and Aweb support sucks
« Reply #24 on: January 09, 2010, 01:59:23 AM »
Better than amiga.org support old iBrowse is that iBrowse be updated;same for AWeb.
Or  if better 68k browser out there ,all classic users switch to  whatever it is and hope/push/pay for work to update it.

Personally,i HATE it when any website refuses to let my "uotdated" browser view the common text-based and still pictures  that are all I really desire without  actually clicking on links/hotspots/ to start videos/audio, etc. But that doesn't fit the PUSH,PUSH idea of many website owners.Some sites require Flash to see anything.

I have old iBrowse buy use Seamonkey or Safari everyday.
 

Offline HammerD

Re: Amiga.org - Ibrowse and Aweb support sucks
« Reply #25 on: January 17, 2010, 10:59:53 PM »
Just like to jump in here...

Amiga.org is primarily a classic amiga site...the fact that it displays like sh*t on classic amigas is just plain WRONG.  Percentages, technologies, everything else aside, this site should be visible on the most popular classic browser, and that is IBrowse.

The fact that I can view Amigaworld.net and Amigans.Net perfectly fine on IBrowse 2.4 just adds to my frustration.

The new owners of Amiga.org should make it a priority to make this site viewable on classic amigas.  IMHO!

I find myself going more to Amigaworld.net and amigans.net these days...
AmigaOS 4.x Beta Tester - Classic Amiga enthusiast - http://www.hd-zone.com is my Amiga Blog, check it out!
 

Offline Gulliver

Re: Amiga.org - Ibrowse and Aweb support sucks
« Reply #26 on: January 17, 2010, 11:22:56 PM »
@HammerD

I am with you on what you said.
I dont understand how come Amiga.org dont support Classic Amigas anymore whilst other PPC Amiga based sites do support them!

So from this Amiga.org change onwards, Amiga.org encourages original Amiga 68k users to buy a graphics card or complain to the browser developer?

If that is the case then i will be forced in the future to look for a site/forum that really does support Amigas. Because times will change, computers will get faster, new technologies will arrive, and my Amiga will be ruled out eventually from Amiga-like sites/forums as this one, but they dont understand i will still cherish my original old Commodore-Amiga, as religiously as a car collector treasures his Ford T model.

Note to myself: Ghz, Terabytes, multiple cores, memory protection, etc rule over an excellent old piece of computing engineering :(
 

Offline Karlos

Re: Amiga.org - Ibrowse and Aweb support sucks
« Reply #27 on: January 17, 2010, 11:35:26 PM »
Quote from: HammerD;538801
Just like to jump in here...

Amiga.org is primarily a classic amiga site...the fact that it displays like sh*t on classic amigas is just plain WRONG.  Percentages, technologies, everything else aside, this site should be visible on the most popular classic browser, and that is IBrowse.


There are a few problems with your statement. You can't throw "percentages" aside and then talk about "most popular" classic browser. I'd be willing to wager the vast majority of visitors to the site before moving to vBulletin were not using IBrowse.

In case you didn't read it, the site was updated to use a new forum engine because there was no other realistic alternative.

Here's a suggestion. I was thinking about doing this myself but I feel lacking in urgency since the only amiga browser I use here is OWB. So, why not learn PHP and write a proxy script that parses whatever page you requested, reformats it to remove all the CSS related guff, converting it (where necessary) to some tables based view and redirect all amiga.org referencing links to pass back through the proxy. Once it's working satisfactorily, ask the new owners nicely if they can make it run on a sub domain. The only tricky bits I can see is session management and the fact it would increase server load when it's used. However that shouldn't be a problem since a tiny percentage of users would actually use it.
int p; // A
 

Offline CountRaven

Re: Amiga.org - Ibrowse and Aweb support sucks
« Reply #28 on: January 18, 2010, 03:38:17 AM »
I wonder what kind of "software machine" / "method" is used behind http://www.amigaworld.net and http://www.amigans.net making them viewable to IBrowse....

Do you know what is the biggest advantage of IBrowse making it still the main browser for classic Amiga users? It is FAST!!!! It is faster on my 030 1200 and faster on my 1200 PPC and even faster on my 4000 PPC. Plus it has a veyr good download manager and some other stuff.

Many bonus points @ NetSurf for bringing CSS @ 68k but sorry to say it is still SLOW so it remains useless in the 68k world.

No I would not count the OWB 68k version cause it was SLOWER THAN HELL even on a PPC.

I basically want to browse the Amiga forums with my classic Amigas, just for fan. Something like "dive into the Amiga world using a real Amiga" thing. OWB offers goods speed under OS4 but what about OS 3.x?

The big goal for me is: Bring the lightness and the speed of Ibrowse to a CSS capable browser -like NetSurf- in 68k an dOS 3.x-

Ok I do not expect to run such a program into an AGA machine @ 020 but it is insane not to have a real fast browser under OS 3.x on Amigas with 128MB RAM and gfx cards.

I will be the first one to donate a real good amount of money for an improved FAST version of NetSurf -or any other browser-.

Perhaps someone can ask for the sources of IBrowse taking em as a guide or something.

Until then: IBrowse rules!!!!!!
« Last Edit: January 18, 2010, 03:47:44 AM by CountRaven »
Peg2, Amiga 500, Amiga 600, Amiga 1200D-030, Amiga 1200PPC, Amiga 4000PPC, CD32, 2xCDTV, Sam 440EP, Efika, AmigaOne XE.

http://www.amigaplanet.gr
 

Offline LoadWB

Re: Amiga.org - Ibrowse and Aweb support sucks
« Reply #29 on: January 18, 2010, 03:47:38 AM »
@Karlos:

Hear hear.  I was going to essentially propose what you have presented, but also add that anyone who requires exacting support for classic Amiga browsers should pony up the money to have an interface designed to do just that.

AO works fine in iBrowse.  I guess I have just become accustomed to scrolling through the slough caused by mis- or non-interpretation of CSS in mobile browsers and Lynx.  You can log in, read messages, post messages, view pictures.

And GHz and other irrelevant sundries do not conspire against working technology, but instead the proponents of aged and arguably obsolete technolgy often conspire against the progression of technology, demanding that it become cumbersome and bulky to provide backwards compatibility, while out the other side of the same mouth complaining about how new technology is "bloated" and using this as an argument for staying with said older technology.

Pfah.  Next we should all complain about how the Internet is not accessible via BBS dialup and interface, or about the death of our FidoNET email addresses.