Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Hollywood MAL AMIStore App Store A600 Memory

AuthorTopic: winuae screenmode setting  (Read 1202 times)

0 Members and 1 Guest are viewing this topic.

Offline Aledt

winuae screenmode setting
« on: May 17, 2007, 02:15:29 AM »
trying to reincarnate my old miggy by using its old drive in my pc under uae (via a usb external drive thingymyjig)

got it booting up, had to remove some of the old stuff (gfx card drivers and soundcard drivers) to get it booting happily and now its all going well. Loaded in the uaegfx drivers for p96 and got a nice full colour representation of my old wb up but only in 640 width resolution.

Whenever i try a different resolution it just hangs up, tried 800 and 1024 resolutions and cant get either to go, just changes to that screenmode and then stops reponding before drawing the screen.

Any ideas how to cure this?

also winuae doenst seem to save my setting do i have to set them all up again every time (for hardware, disks, etc.)
cheers.
 

Offline SamuraiCrow

Re: winuae screenmode setting
« Reply #1 on: May 17, 2007, 03:24:07 AM »
Quote
also winuae doenst seem to save my setting do i have to set them all up again every time (for hardware, disks, etc.)


In order to make WinUAE save your profile you have to go to the "configurations" settings and hit "Save As..." and then when you want to reload them go to the "configurations" settings and click the one you want and hit "load".

As for the settings under P96, do you have enough video RAM configured under the RAM settings?
 

Offline Aledt

Re: winuae screenmode setting
« Reply #2 on: May 17, 2007, 01:12:23 PM »
yeah, ive set it to 32mb (which should surely be more than enough?)

ive deleted all the old modes picasso4 modes from p96mode prefs, do i need to change anything in pvs too? still not working.

it changes to the new resolution and the mouse pointer changes to a clock and then it just stops.
 

Offline Aledt

Re: winuae screenmode setting
« Reply #3 on: May 17, 2007, 01:22:29 PM »
bah, ok i got it working, deleted the old screenmode.prefs and  set it up to start in 1024 mode.

redrawing reaction guis seems painfully slow, mui guis draw up fine, but anything using reaction seems to draw everything incredibly slowly, also the original utilities/clock takes ages to draw, is this just a "feature" of uae or is there a setting im missing somewhere? i was expecting it to be wquicker than my old 040 system.
 

Offline SamuraiCrow

Re: winuae screenmode setting
« Reply #4 on: May 17, 2007, 02:59:57 PM »
Reaction didn't get terribly optimized until version 4.0 of AmigaOS and, therefore, will be slow on WinUAE as well.  Keep in mind that you're running the 68k version of P96 so that runs emulated rather than native as well.
 

Offline Aledt

Re: winuae screenmode setting
« Reply #5 on: May 17, 2007, 08:12:12 PM »
fair enough, guess ill have to go change all the reaction prefs to boring old plain colours.

Still have that probvlem with changing screenmodes, seems to hang whenever switching to a different p96 mode (eg when an app tries to open a new screen).
 

Offline coldfish

Re: winuae screenmode setting
« Reply #6 on: May 18, 2007, 03:13:46 AM »
You cant change resolution in WinUAE on the fly, you have to set WinUAE's resolution before booting the emulated Amiga, save that into a configuration then boot the emulated environment.

If you intend the Amiga side to operate at 720x576 then the WinUAE resolution needs to be at least that to fit the Amiga screen in, say 800x600 centered.

With some PC side, driver tweaking you can get modern video cards to output PAL and NTSC resolutions and get a fairly faithful reproduction of a classic Amiga.

I think I'm answering your question?
 

Offline Aledt

Re: winuae screenmode setting
« Reply #7 on: May 18, 2007, 02:17:03 PM »
no, im not fussed about pal resolutions, havent used them in years anyway, winuae starts in a pal resolution fine anyway. It then switches to fullscreen (1024) when WB loads because its using the uaegfx driver for picasso96. Its when the amigas screenmode changes within uae that it hangs.
 

Offline coldfish

Re: winuae screenmode setting
« Reply #8 on: May 20, 2007, 06:00:45 AM »
Hmm, sorry for the misunderstanding.

I'm not sure what's going on in that case, guess it is something to do with the Amiga side?

I use WinUAE for games mostly and a little AIAB now and then.