Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A600 Memory

AuthorTopic: Is There A Demo Of Quake II  (Read 3196 times)

0 Members and 1 Guest are viewing this topic.

Offline humppa

Re: Is There A Demo Of Quake II
« Reply #45 on: December 21, 2005, 02:33:36 PM »
@trgse

Could you maybe upload it somewhere else until the issues are sorted out?
 

Offline AmigaMance

Re: Is There A Demo Of Quake II
« Reply #46 on: December 21, 2005, 03:01:56 PM »
 I have the .exe from the link that nasty posted. So let me see if i get it straight. If i buy the PC version of Quake 2, i will be able to play the game from my Amiga? At least in theory, since ppl reporting problems with this port.
A1200 PPC user.
 

Offline humppa

Re: Is There A Demo Of Quake II
« Reply #47 on: December 21, 2005, 03:20:23 PM »
Yes, you need the data files from your Q2-CD. These are the PAK-files from the "ID1" directory.
The other Quake1/Heretic ports work just in the same way.
 

Offline AmigaMance

Re: Is There A Demo Of Quake II
« Reply #48 on: December 21, 2005, 03:30:01 PM »
 Ok, this is great. :-)
A1200 PPC user.
 

Offline AmigaMance

Re: Is There A Demo Of Quake II
« Reply #49 on: March 10, 2006, 07:29:00 PM »
 Damn, it doesn't work! :..-(
 I get an empty grey screen and nothing else. The CPU becomes 100% busy until i do a reset.
 The shell window in which i run quake2 promts this text:

Vid_MenuInit
Weiter
GL_SetDefaultState
GL_InitImages
Mod_Init
R_InitParticleTexture
Draw_InitLocal
GLError ??
Nein
SNDDMA_INIT
test4
 0 mal
GLimp_EnableLogging
SNDDMA_INIT
SNDDMA_INIT  


 I have a BPPC with a BVision. I would like to see some feedback from users with similar setup or any ideas to make it work. Thanks.
A1200 PPC user.
 

Offline AmigaMance

Trying to make Q2 work
« Reply #50 on: March 11, 2006, 02:32:12 PM »
Hi again. I'm still trying to make it work.
I read in the installation intructions that if i get a gray screen (exactly like in my case) i must set variable gl_mode "0" in the config.cfg file. In the Q2 CD that i got there was not such file in the BaseQ2 directory, here are its contents:

gamex86.dll               357376
pak0.pak                18399773
players                      Dir
video                        Dir

 So, i just used a text editor to create the file and enter gl_mode "0" as its first line.
 I tried to run the game again but nothing.. the same gray screen with no sound or anything.
 I could appreciate some help here, from what i read there is at least one person with similar setup, who was able to start the game.
A1200 PPC user.
 

Offline Vincent

Re: Trying to make Q2 work
« Reply #51 on: March 11, 2006, 05:06:44 PM »
IIRC it should be:

set gl_mode "0"
Xbox360
"Oh no. Everytime you turn up something monumental and terrible happens.
I don\'t think I have the stomach for it." - Raziel
 

Offline AmigaMance

Re: Trying to make Q2 work
« Reply #52 on: March 11, 2006, 07:08:30 PM »
@Vincent
 I have just try it and it didn't work either. :-(
A1200 PPC user.
 

Offline Vincent

Re: Trying to make Q2 work
« Reply #53 on: March 11, 2006, 08:13:19 PM »
Bummer, that's how it's written in the pc's file.

I don't know what else it could be.
Xbox360
"Oh no. Everytime you turn up something monumental and terrible happens.
I don\'t think I have the stomach for it." - Raziel
 

Offline humppa

Re: Trying to make Q2 work
« Reply #54 on: March 14, 2006, 04:46:58 PM »
Since Quake2 is already GPL'ed for a long time now, I am wondering why nobody has picked it up yet and created an alternative to the commercial version from Hyperion.

We have seen lots of ports for Doom, Quake, Heretic and so on,  but why is there nobody interested in doing a WOS-port for Quake2? Or am I missing something here?
 

Offline Lando

Re: Trying to make Q2 work
« Reply #55 on: March 14, 2006, 05:56:47 PM »
Quote

humppa wrote:
Since Quake2 is already GPL'ed for a long time now, I am wondering why nobody has picked it up yet and created an alternative to the commercial version from Hyperion.

We have seen lots of ports for Doom, Quake, Heretic and so on,  but why is there nobody interested in doing a WOS-port for Quake2? Or am I missing something here?


There is a MorphOS version since several years, and the source code from Hyperion's AmigaOS version is on Aminet for anyone who wants to rebuild it and put the WOS or 68k executable online.  Obviously if you make any changes / improvements to the source then you have to make those available, as it is under GPL.

I don't know why nobody did it yet, but there are very few Amiga developers left now, and those that are left are working on other projects, and Quake 2 was a very old game even 4 years ago when the Amiga version appeared.
 

Offline humppa

Re: Trying to make Q2 work
« Reply #56 on: March 16, 2006, 12:12:35 PM »
Quote
I don't know why nobody did it yet, but there are very few Amiga developers left now, and those that are left are working on other projects, and Quake 2 was a very old game even 4 years ago when the Amiga version appeared.


"Old game", ok, but which "new games" could we still run on Classic PPC hardware anyway?

I would really love to see a non-commercial port. I still hope somebody finds the time, what about Frank Wille, Christian Michael, Massimiliano Tretene?

Could somebody upload quake2.lha somewhere? Is this the betaversion (v0.5) of Frank Menzel? On Fileplanet it say "Amiga Quake II 3.9" though.
 

Offline Seiya

Re: Is There A Demo Of Quake II
« Reply #57 on: March 31, 2006, 12:25:15 PM »
Hyperion said that quake II engine is faster than original quake I..
If you find quake II, you can try..

Imho, i don't think so..because
on my amithlon system quake run about 60 fps (timedemo)
in 640x480, while quake II at the same resolution get only 32 fps (timedemo 1, map demo1.dm2)

On a real 68k Amiga quake II could be very very slow (in software mode) but fast with Warp3D (i hope)

Offline zipper

Re: Is There A Demo Of Quake II
« Reply #58 on: March 31, 2006, 02:18:27 PM »
http://www.amigaspeed.de.vu/

QuakeII timedemo 12 - 30 fps depending on resolution, CSPPC233/Voodoo.
 

Offline ddniUK

Re: Is There A Demo Of Quake II
« Reply #59 on: December 05, 2006, 09:22:10 AM »
HI all can anyone help here.

On running the Quake2 amiga executable, I get the error "sys_error couldnt open pics/colormap".

I have assigned properly, I think!

Assign baseq2: quake2:baseq2

Any ideas?