Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A600 Memory

AuthorTopic: Linux UAE vompile error  (Read 1233 times)

0 Members and 1 Guest are viewing this topic.

  • Guest
Linux UAE vompile error
« on: March 21, 2003, 09:49:06 PM »
Hi!

I try to compile UAE 0.8.22 under Redhat 8.0 like this:
sh configure
make

then it says this:
./tools/cpuopti cpufast.s
Corrupted assembly file!
Internal error; file /home/jan/uae-0.8.22/src/cpuopti.c, line 28
make[1]: *** [cpufast.s] Fehler 134
make[1]: Verlassen des Verzeichnisses Verzeichnis »/home/jan/uae-0.8.22/src«
make: *** [all] Fehler 2

i've read that it can solved with another compiler version, but how?

had anybody an idea?

please help

Kabaal.
 

Offline Siggy

Re: Linux UAE vompile error
« Reply #1 on: March 22, 2003, 12:19:17 AM »
I've had problems tinkering with 8.22 under Mandrake - even after getting the source RPM's and rebuilding / patching.

unless there is a particular feature you need (like running it SVGA), I'd suggest downloading the binary RPM and installing 8.21 (it's probably on one of your disks already) - I've got RPM's with and without the JIT compiler and both had bsd_socket option compiled already.

Siggy.

Quote
The TV business is uglier than most things.
 It is normally perceived as some kind of cruel and shallow money trench through the heart of the Journalism industry, a long plastic hallway where thieves and pimps run free and good men die like dogs,
 

Offline Darth_X

Re: Linux UAE vompile error
« Reply #2 on: March 22, 2003, 04:52:27 AM »
Linux Vampire?


There's a new one..

 

  • Guest
Re: Linux UAE vompile error
« Reply #3 on: March 24, 2003, 03:35:36 PM »
sorry, i mean compile, not vompile (hmpf :-x )

i installd the redhat rpm but it dont suport the fullscreen mode  :-(

then i try the mandrake rpm. it runs in fullsreen but has no sound  :-(

... if i can't take care of this i try to run winuae under a windows emulator  :-P
 

  • Guest
Re: Linux UAE vompile error
« Reply #4 on: March 24, 2003, 04:26:53 PM »
Try compiling with an earlier version of GCC, such as 2.95.

Do something like this when configuring:

CC=gcc-2.95 ./configure

and remember to supply your configure options on the same line.
 

Offline Siggy

Re: Linux UAE vompile error
« Reply #5 on: March 26, 2003, 04:11:16 AM »
Sorry I didn't reply for a while... but here's something for you to look into:

In the directory you run UAE from (more than likely your home directory) look for a file called .uaerc

This is a config file that UAE will read it's config from.. in there you can turn on your audio.

Alternatively, boot UAE with it's interface (not full screen) - use the GUI to set up your configs till you're happy with them and save the config (.uaerc) and then boot full screen from there on in.

Personally I copied UAE to a local bin directory and wrote some shell scripts to set me up properly. I also put my home directory as a local drive, so to change config I load up a text editor, modify, reboot.
Never leave UAE.

(Hmm maybe I should write a little amiga GUI frontend for this.....)

Another interesting dirty trick.
Don't run UAE full screen at all (personal pref here, I don't like linux programs running as root).
Instead run with a minimal window manager - something like AmiWM -- or alternatively no WM at all.  Boot up this configuration from a shell script (mine is simply called goami) -- setup UAE with the same screen res as you run Xwindows at.
Under Xwindows (with no WM) it looks as it if it is running at fullscreen - under AmiWm you have a 'Amiga screen bar' at the top of your screen (pull down that screen and have a Linux WB running behind it)..
Why would you do this? Well it all works together for the ultimate dirty trick:

Set up a crontab task and a shell script to check a subdirectory every minute or so (up to you how often) and execute whatever scripts it finds in there (this is why you DON'T run UAE as root -- and I'm currently working on a way to do this that isn't a security nightmare :P ) - make 'start scripts' for your fave 'can't live without' linux progs -- Your fave webrowser, xmms, whatever...
From the amiga side, make scripts that copy these "starters" to the "execution draw" and link them to icons (tool of your choice).

Result - you hit a button on your WB in UAE - 30 secs later you get Mozilla running.
If you use AmiWm, it's window sizing gadgets will look like WB 2.0 - so you're not distracted.


It's cheap, it's dirty, it's fun.

Siggy
 

Quote
The TV business is uglier than most things.
 It is normally perceived as some kind of cruel and shallow money trench through the heart of the Journalism industry, a long plastic hallway where thieves and pimps run free and good men die like dogs,
 

  • Guest
Re: Linux UAE vompile error
« Reply #6 on: March 30, 2003, 08:39:37 PM »
first thx for your help.

i try to compile uae to set configs like "use sdl". so i have to compil it anyway.

i tryed it with this:

CC=gcc-2.95 ./configure

but now it says this:

loading cache ./config.cache
checking for gcc... gcc-2.95
checking whether the C compiler (gcc-2.95  ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.

hmmm seemst that i dont have the right compiler version.

 :-(
 

Offline falemagn

Re: Linux UAE vompile error
« Reply #7 on: March 30, 2003, 09:26:22 PM »
Quote
hmmm seemst that i dont have the right compiler version.


Unfortunately the uae's assembly optimizer doesn't work with the assembly output of gcc 3.x, so you either use gcc 2.95, or you just disable assembly optimization. You can do that easily by issuing this command, once the compilation stops:

    cp cputmp.s cpufast.s

in the uae-/src directory, and then run "make" again.
 

  • Guest
Re: Linux UAE vompile error
« Reply #8 on: April 01, 2003, 09:07:12 PM »
 cp cputmp.s cpufast.s

in the uae-/src directory, and then run "make" again.


Wow, thanks man, that was a direct hit!

I dont understand why  :-o  but uae runs now.

Thanks very mutch.
 

Offline Crumpster

Re: Linux UAE vompile error
« Reply #9 on: April 02, 2003, 06:38:09 PM »
Cheers guys,

I accidentally tripped over this thread and now I'm glad I did.

I'm on my home RH8.0 system and was having exactly the same probs.

did the: CC=gcc-2.95 ./configure

and the: cp cputmp.s cpufast.s

Worked a treat.  :-o

Cheers fellas.

Crumpster
A1-XE - G4 800MHz, 1GB RAM, 80GB HDD, Radeon 9250, OS 4.1
A1200T - PPC603 240MHz / 68040 50MHz, 128MB RAM, Mediator, OS 3.9 / 4.1
A1200 (No. 2) - M-TEC 68030 50MHz, 4GB CF, KS 3.0, OS 3.0
A500 - ACA500 with ACA1232.
CDTV - in Progress: SCSI, 9 pin joy/mouse connectors, KS switcher.

Non-CBM - Atari STe, Atari Falcon, Apple ][e, ZX Spectrum, CPC6128.
Gone but not forgotten (and slowly getting them back): CPC464, C64, Vic-20.

I may have a problem