Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: E-UAE Mac OS X  (Read 1901 times)

0 Members and 1 Guest are viewing this topic.

Offline wildstar1063

E-UAE Mac OS X
« on: August 07, 2005, 03:08:36 AM »
I finally figured out why I could not get E-UAE to work on OS X

You need to download and install the SDL Libraries from here:

http://www.libsdl.org/release/SDL-1.2.8.pkg.tar.gz
 
E-UAE won't work without them.

Then move your E-Uae folder to where ever you want it.

By defalt, E-UAE expects your "default.uaerc" Configuration file to be in your
Personal folder in OS X.

Edit your default.uaerc either by manually creating one with a text editor
or by using the HI-Torro GUI front end. Remember to save it to your personal folder in OS X.

Then you can just click on UAE and it will load your virtual Amiga.

E-UAE seems much faster than MaxUAE and the mouse tracking is much
 better.

Below is the text of my default.uaerc if you want to copy it to a text file
 you will need to edit the folderr locations for the drives and the rom
location.

Chuck (Wildstar1063)



config_description=UAE
config_info=Test Info
kickstart_rom_file=/Volumes/Work/OSX Apps/Emulation/MaxUAE Beta/Kick.rom
kickstart_key_file=
kickstart_ext_rom_file=
cart_file=
kickshifter=false
chipmem_size=4
fastmem_size=8
bogomem_size=0
z3mem_size=32
gfxcard_size=2
log_illegal_mem=false
cpu_type=68040
cpu_24bit_addressing=false
cpu_compatible=false
cpu_cycle_exact=false
cpu_speed=max
cachesize=3072
comp_nf=false
comp_fpu=true
compforcesettings=false
comp_trustbyte=indirect
comp_trustword=indirect
comp_trustlong=indirect
chipset=ecs
ntsc=true
fast_copper=true
immediate_blits=true
collision_level=sprites
gfx_width=800
gfx_height=600
gfx_width_fullscreen=800
gfx_height_fullscreen=600
gfx_width_windowed=800
gfx_height_windowed=600
gfx_linemode=double
gfx_center_horizontal=simple
gfx_center_vertical=simple
gfx_fullscreen_amiga=false
gfx_fullscreen_picasso=false
gfx_lores=false
show_leds=true
gfx_correct_aspect=true
gfx_framerate=2
sound_output=normal
sound_channels=stereo
sound_interpol=none
sound_bits=16
sound_frequency=44100
sound_max_buff=8192
floppy0type=0
floppy1type=0
floppy2type=0
floppy3type=0
floppy0=
floppy1=
floppy2=
floppy3=
floppy_speed=100
filesystem2=rw,DH0:System:/Volumes/Work/OSX Apps/Emulation/MaxUAE Beta/System,-10
filesystem2=rw,DH1:Work:/Volumes/Work/OSX Apps/Emulation/MaxUAE Beta/Work,-10
kbd_lang=us
joyport0=mouse
joyport1=kbd1
sdl.map_raw_keys=false
scsi=true
scsi_device=IOCompactDiscServices/0
bsdsocket_emu=true
serial_on_demand=true
parallel_on_demand=true
# WORKBENCH
# filesystem=rw,AmigaOS3.9:AmigaOS3.9
# amiga GFX depth & fullscreen
macosx.bit_depth=32
macosx.screen=2
# THE ROM FILE!
# FLOPPIES
# SOUND OUTPUT
# joy0 = mouse, joy1 = keyboard (numpad)
# amiga GFX
# MEMORY (2M chip, 4M very fast, 2M gfx)
a3000mem_size=64
# MISC
macosx.rom_path=./
macosx.floppy_path=./
macosx.hardfile_path=./
use_gui=yes
accuracy=2
Amiga 3000T with 12Megs-SCZ, G-Force 040 28mhz, Delfina Lite, CyberVision 64/3D, QuickNet-2000 Ethernet, 2gig IBM , CD Rom and external Zip 100 Also Fastlane Z3 board and Amax IV whenever I install them.
Also an A600, and an A3000D bone stock, with 12...