Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: Amithlon graphics trouble...  (Read 1183 times)

0 Members and 1 Guest are viewing this topic.

Offline ple3003

Amithlon graphics trouble...
« on: March 03, 2003, 03:34:24 PM »
I recently bought an Epox 8rda+ (nforce2) to use with my Radeon 8500. But Amithlon just wont boot up with @amithlon, only @small, and that with only some blurred graphics screen...
I've tried the newest kernel build, as well as the special ATI kernel, and neither helps...
According to other amithlon users, the 8rda+ should work just fine with amithlon, so i guess the radeon is the cause of trouble.
Extra info: All PCI-slots empty, BIOS taking care of IRQ:s and DMA:s and so on (PNP).

Anyone have an answer to this?
bap bap bap bapbaaa

Offline Kronos

  • Resident blue troll
  • Hero Member
  • *****
  • Join Date: Feb 2002
  • Posts: 4017
  • Total likes: 0
    • http://www.SteamDraw.de
Re: Amithlon graphics trouble...
« Reply #1 on: March 03, 2003, 04:09:44 PM »
Have you tried adding video=vesa to your lilo/grub command-line ?
1. Make an announcment.
2. Wait a while.
3. Check if it can actually be done.
4. Wait for someone else to do it.
5. Start working on it while giving out hillarious progress-reports.
6. Deny that you have ever announced it
7. Blame someone else

Offline ple3003

Re: Amithlon graphics trouble...
« Reply #2 on: March 06, 2003, 05:50:53 PM »
I use loadlin.exe to bootup amithlon...
I have tried video=dovesa in the "small" cfg-file.
I get the same result - a kickstart image, you know the purple one with a disk and a diskdrive (but it's heavilly distorted), like if the "small" image just wont load or something...
bap bap bap bapbaaa

Offline bhoggett

Re: Amithlon graphics trouble...
« Reply #3 on: March 13, 2003, 01:45:33 PM »
Uh, oh.

Sorry for missing this thread previously. (It's in the wrong forum category. Could one of the moderators please move it?)

Getting back to the issue at hand, the answer seems simple to me: don't use "small". You're not ready for it.

The "small" option, which loads the smallird.gz ramdisk image does not contain a bootable AmigaOS partition in RAM as the bigird.gz image does, and since you haven't had a chance to set up a hard disk AmigaOS bootable partition either, the kickstart is just trying to display the old "insert boot disk" screen. However, as this screen is usually displayed on an AGA chipset display which is not emulated by Amithlon, you are getting a corrupted screen.

You need to locate the script that uses bigird.gz instead of smallird.gz, and use that with loadlin. I think it's just called "amithlon". Don't foget to use the "dovesa" bit as well.
Bill Hoggett