Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Hollywood MAL AMIStore App Store A600 Memory

AuthorTopic: Problem with sound in OS 3.9!  (Read 807 times)

0 Members and 1 Guest are viewing this topic.

  • Guest
Problem with sound in OS 3.9!
« on: February 04, 2003, 03:02:23 PM »
Hey

I have install OS 3.9 with WinUAE!!

someone also running a emulated OS 3.9?

if yes

Does your sound work 100%?

because

When I try to run a game with sound is run slow, if I run without sound, then is normal!!

Does anyone have a config file for winUAE where the sound is perfect for OS 3.9?

or

Maybe try to help me with it

First my pc specs:

Athlon 1.2 Ghz
400 MB ram
Geforce 4 MX
Soundblaster Live

My WinUAE is the newest

My Winuae Settings:

Chip RAM: 2MB
Fast RAM: none
Slow RAM: nne
Z3-Fast RAM: 16 MB
RTG (Graphics card)

Rom: Kick 3.1

CPU: 68020+FPU

Emulation Speed: Fastest Possible, but maintain chipset timing

Detect idle CPU: Disabled

JIT Settings:

Cache Size: 4 MB
Hard flush: disabled Force Settings: disabled Const Jump: enabled No Flags: Enabled FPU Support: enabled

Sound:

Enabled, 100% accurate
44100 Hz
Stereo

Use Primary DirectSound Buffer: Enabled

Sound buffer size: 3

Interpolation: Disabled

It this a WHD game
 

Offline redrumloa

  • Original Omega User
  • Hero Member
  • *****
  • Join Date: Feb 2002
  • Posts: 10126
  • Total likes: 0
Re: Problem with sound in OS 3.9!
« Reply #1 on: February 04, 2003, 03:06:36 PM »
Reinstall Direct-X 8.x, probably the problem.
Someone has to state the obvious and that someone is me!
 

Offline redrumloa

  • Original Omega User
  • Hero Member
  • *****
  • Join Date: Feb 2002
  • Posts: 10126
  • Total likes: 0
Re: Problem with sound in OS 3.9!
« Reply #2 on: February 04, 2003, 03:10:52 PM »
Oh yeah disable primary sound buffer!!!!

Quote
 primary sound buffer-checkbox removed and disabled. It is useless and usually
  only caused huge slowdown problems. NOTE: Users of R3 or R4: Make sure primary
  sound buffer-checkbox is disabled.
Someone has to state the obvious and that someone is me!
 

Offline Desolator

Re: Problem with sound in OS 3.9!
« Reply #3 on: February 04, 2003, 03:53:59 PM »
lower the Khz to around 22.000 in the sound property tab in WinUAE and switch over to Mono. I know, it sounds a bit rough but you get fluent graphics that way. :)
// Amiga - The computer for the creative mind.
// Ph.D in Amiga future optimism.
 

Offline redrumloa

  • Original Omega User
  • Hero Member
  • *****
  • Join Date: Feb 2002
  • Posts: 10126
  • Total likes: 0
Re: Problem with sound in OS 3.9!
« Reply #4 on: February 04, 2003, 04:23:01 PM »
Quote

Desolator wrote:
lower the Khz to around 22.000 in the sound property tab in WinUAE and switch over to Mono. I know, it sounds a bit rough but you get fluent graphics that way. :)


Really? Maybe my system is just really really fast? I run emulated 100%, stereo, 44100, everything! No slow downs! I can even play games like Payback or Quake and get real good frame rates :-o I have a AtlonXP 2000 w/DDR 333 MB
Someone has to state the obvious and that someone is me!
 

Offline Desolator

Re: Problem with sound in OS 3.9!
« Reply #5 on: February 04, 2003, 04:25:21 PM »
Well, I only got a measly PII 450 so I wouldn't know... :) On low-end systems this is a good way to improve framerates in games.
// Amiga - The computer for the creative mind.
// Ph.D in Amiga future optimism.
 

  • Guest
Re: Problem with sound in OS 3.9!
« Reply #6 on: February 04, 2003, 04:40:40 PM »
hmm....My OS 3.9 will not start in WinUAE if I disable Primary DirectSound Buffer