Operating System Specific Discussions => Amiga OS => Amiga OS -- Development => Topic started by: slaapliedje on October 23, 2019, 04:41:14 AM

Title: Bug in Long Filename FFS support in 3.1.4? (Trying to install VT 4.3 off CD).
Post by: slaapliedje on October 23, 2019, 04:41:14 AM
So, I think I've ran into a bug with 3.1.4.
I have been having all sorts of hell trying to get the Video Toaster software to install from and getting the install to actually work.

I have tried the following; format drives from 3.1.4 hdtoolbox with FFS and long file name support (120gb SSD through FastATA 4000 MK VI), split with 3.5gb Workbench: drive, 52gb Work: and the rest Games:.  The Newtek and Toaster folders are on Work:, I have tried using either the 3.1.4 CD0 driver to mount the CD of VT_4.3 and a gotek as the floppy drive.  Or with the FastATA driver / AllegroCDFS (which had other issues as well, but I sent an email to Elbox about that).

Problem I run into is that I get the 3.5(?) version installed as it suggests, then I try the 4.3 install and it always just hangs on 'Installing AI.dat'.  SnoopDOS says it got further than that, but it never shows as such in the install dialog.

Now I know this is FFS (or maybe just the long file name support) because if I switch to PFS3, it gets further.  It then gets to the point of prompting for what plugins, demos, etc to install, and I go through the dialogs that have everything selected by default.  But then it sticks on 'proceed anyway' after it says I need at least 350mb of space.  But it won't go further, I can click proceed until my mouse breaks and it won't go further.  But, if I start the installer with 'sys:system/installer 4.2Install' then it'll go further than that, but then something else always likes to get in the way (the aforementioned FastATA issues, sadly I don't currently have a long enough cable for the onboard IDE to reach my CD-ROM at the moment to test the onboard IDE).

Any thoughts on this?  I know I've ran into the installer bug before (with AsimCDFS) where I had to use the much newer Installer program so that it could properly calculate the free disk usage of large partitions.
Title: Re: Bug in Long Filename FFS support in 3.1.4? (Trying to install VT 4.3 off CD).
Post by: guest11527 on October 23, 2019, 07:33:23 AM
I'm sorry, I only understand half of what you have written. First, which hardware is this? Second, what is the drive connected to, i.e. which type of host adapter. Third, what are the precise activities? Is there a file system in the RDB? If so, which one? What is its type? What is "further"? Which commands are issued? What is the snoopdos output?

From what I understand, this can be anything. Bad cabling, bad device, bad sectors, missing SCSI termination and so on. Please be aware that we did test FFS, so it is a bit premature to blame the file system for the problem (whatever the problem might be).
Title: Re: Bug in Long Filename FFS support in 3.1.4? (Trying to install VT 4.3 off CD).
Post by: slaapliedje on October 23, 2019, 09:25:55 AM
This is an A4000D (slapped into a tower).  I don't have a long enough cable currently to test the onboard IDE (on order) so all the testing is from a FatATA 4000 Mk VI.  HDD is on the primary master, CD Rom is on the secondary master.

I backed up the drive that came with this system, then copied it onto my existing partition layout, so at first I thought it was old cruft from the previous owner's setup, but since the installer worked when all three partitions were pfs3, but not FFS, it sounds like I encountered a weird bug.  This happens with either the Installer from workbench (45.something),  or the one on the disk (which I would have to check again the version.)  SnoopDos was listing I think three more files.  I tested this multiple times, since the fastATA is being crap and forcing me to reformat and then back and forth to my PC to restore the backup.
I think my next step should probably be to try a fully clean setup with it and see if it still does it.  Will try that after I get home from work.  By clean I mean absolutely nothing on the drive.  I always clean up the boot drive when testing.  But I have done it enough times and wanted to test the newer filesystem.
If anyone else can rry installing the Video Toaster software on a large drive, would be nice to know I am not just cursed :p
Title: Re: Bug in Long Filename FFS support in 3.1.4? (Trying to install VT 4.3 off CD).
Post by: slaapliedje on October 23, 2019, 11:15:36 AM
(Sign #8 that you're getting old,  you tell 'stories' of when you were  younger)
When I was a young lad, I would always be playing around on a computer and trying to do something cool.  As soon as I got that thing to work, I'd run to tell my friends to 'check this out!' and inevitably, it would fail to work again how I had it working just a small amount of time before!
As I get older, I now find the opposite is true.  I keep having issues with something, and the damn thing won't work after testing all sorts of different variables.  Finally complain to someone else that it's broken, and then suddenly it works magically, once again making me look the fool!

So this time I took HDToolbox, changed the drive so ti was the Kingston (instead of what 3.1.4 set it to be under WinUAE (which was UAE-IDE or something, only way I could get the install disk to detect a hard drive was to set WinUAE to emulated the A3000/4000 IDE).  I changed the partition names to HD# instead of KDH#, and otherwise left everything set to International FFS.  Rebooted, formatted the three partitions and named them as what I did before, rebooted again, installed 3.1.4, rebooted, saw it complain about the 060 libraries, installed them, rebooted.  Copied over SnoopDOS 3.9, opened it up, and installed VT 3.1 with the floppy image and CD in the drive, everything worked fine.  Then used the 4.2Install off the floppy disk, and unlike before it didn't get to the point where it warns that it'll take 350mb of disk space and then not let me proceed, it worked fine and copied everything over.  A long while later, I fired up the VT and it's working just fine! 

Only thing I can think of was causing the issues is maybe some write protection on some of the files on the Work: partition (as I had multiple times tried cleaning off all of Workbench and starting fresh).  Now I'll probably end up installing BestWB1.2 or the Update to  I'm not sure on which I should install first at this stage (I think last time it seemed better to do BestWB then  Sorry for blabbing out at the wee hours of the morning.  Been trying to get the newer version of the VT software installed for like a week now.
Title: Re: Bug in Long Filename FFS support in 3.1.4? (Trying to install VT 4.3 off CD).
Post by: guest11527 on October 23, 2019, 08:20:49 PM
While thinking about it, one possible explanation is that you created a FFS partition that is larger than 4GB. The new FFS can handle this, but programs requesting the partition size, and computing from the information they get a byte-size may get confused, and may wrongly come to the conclusion that the disk is full because they only operate with 32-bit numbers.

We had the issue of "weird partition sizes" multiple times when testing 3.1.4, and had to extend multiple programs for 64 bit math (i.e. the workbench and the info command, both of which showed nonsense-numbers for large partitions).
Title: Re: Bug in Long Filename FFS support in 3.1.4? (Trying to install VT 4.3 off CD).
Post by: slaapliedje on October 23, 2019, 09:38:59 PM
Yeah, the installer for AsimCDFS I know has this issue, as it shows available space in the negatives.  As long as you use the newer installer, it will install fine. 

Which does bring up a question.  Historically I have always seen Installer in C:, but mostly have used OS3.9.  3.1.4 puts it in SYS:System.  Was that always standard, and I have just been running into the oddball installer script that wanted it to be in C:?