Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

AuthorTopic: IDE CDROM questions for TF536 with A2000.  (Read 1631 times)

0 Members and 1 Guest are viewing this topic.

Offline Pat the Cat

Re: IDE CDROM questions for TF536 with A2000.
« Reply #30 on: October 15, 2021, 02:03:19 AM »
Good call.

I thought they were trying to use a Playstation controller as a mouse or something.  :'(
"To recurse is human. To iterate, divine."

A1200, Vanilla, Surf Squirrel, SD Card, KS 3.0/3.z, PCMCIA dev
A500, Vanilla, A570, Rev 5, KS 1.2/1.3 Testbench system
Rasp Pi, UAE4ARM, 3D laser scanner, experimental, hoping for AmigaOS4Arm, based on Watterott Fabscan Pi
 

Offline part12studios

Re: IDE CDROM questions for TF536 with A2000.
« Reply #31 on: October 15, 2021, 03:36:07 AM »
yea understood about adapter.. figured as much.. was just checking.  no one would make amiga ps/2 adapters if existing pc adapters worked..  still pretty common.. 

so at this point i'm pretty sure it must be the fuse..  so i'm going to see about troubleshooting it and getting the fuse replaced..  i do need to first find out what pins have voltage and do a basic multimeter check.  if anyone knows which pins to check against i'd appreciate the tip! (ha! see what i did there?)

I need to take my box into a local repair guy to replace the varta.. i could probably do that myself but now that i know this fuse needs changing it just makes it that much better.. i'd rather pay someone more skilled with a soldering iron locally..   he's reasonable.  probably $40-50..   he's installed various composite mods for me for the same price.. and i'd rather do this than ship it at this point.. 

I can confirm as well that at least the L Amiga + arrow keys moves the cursor around as well..  so basically i need to service the two floppy drives, replace the fuse for the mouse.. i do wish i knew what caused the fuse to pop in the first place..  that bothers me some..  just because i don't want it to just pop again.
 

Offline part12studios

Re: IDE CDROM questions for TF536 with A2000.
« Reply #32 on: October 15, 2021, 03:50:29 AM »
https://www.youtube.com/watch?v=6jz_UrKJKxM this was a nice video.. but there's also this video showing a shortcut (basically leaving the old fuse) which i see is pragmatic but i must say i kinda prefer doing the full replacement..  will have to check with my guy. https://www.youtube.com/watch?v=syDCZh7U_XM

Offline Pat the Cat

Re: IDE CDROM questions for TF536 with A2000.
« Reply #33 on: October 15, 2021, 03:05:02 PM »
Well... if you're not getting +5V on the connector, fuse F1 does indeed look like the cause.

A logic probe helps a lot diagnosing which pins are high, low or changing. Much more accurate than a multimeter.

All Amiga ports except the phono connectors for video and audio have a power pin, that's why you have to be careful to plug in things that are "Amiga compatible" with the power off.

Ideally. I daresay people have come a cropper before with 2 player games and switching out the mouse for a 2nd joystick. Although joysticks usually don't need power, maybe it's only an issue for controllers that do need power.
"To recurse is human. To iterate, divine."

A1200, Vanilla, Surf Squirrel, SD Card, KS 3.0/3.z, PCMCIA dev
A500, Vanilla, A570, Rev 5, KS 1.2/1.3 Testbench system
Rasp Pi, UAE4ARM, 3D laser scanner, experimental, hoping for AmigaOS4Arm, based on Watterott Fabscan Pi
 

Offline part12studios

Re: IDE CDROM questions for TF536 with A2000.
« Reply #34 on: October 15, 2021, 03:50:00 PM »
if the CIA chip were bad could this cause no 5v?  I'm trying to pre-diagnose the issue before I take it to my guy who's not an amiga technician, but knows his way around a computer for sure, just makes the work quicker / more effective.. 

logic probe?  oh i see, i've never seen one of those before, just googled.  interesting.  I'll have to look into getting one of these.  I figured one of the pins has a constant +5 volt on it standard.. like pin 1 or something.. i just didn't want to start poking around with metal while on.. and zorch something..

So it's possible that a passive mouse like a ball mouse might actually work? 
 

Offline Matt_H

Re: IDE CDROM questions for TF536 with A2000.
« Reply #35 on: October 15, 2021, 05:38:38 PM »
This might help, although it’s geared toward the 4000. The site is run by @Castellen, a user here and a master of Amiga repair knowledge.

Offline part12studios

Re: IDE CDROM questions for TF536 with A2000.
« Reply #36 on: October 15, 2021, 05:42:33 PM »
which pin is pin 7?  thanks for that link!  definitely good but i'm no good at reading diagrams at least in relation to how they read looking at the db9 is it:

1  2  3  4  5
  6  7  8  9

?
 

Offline Matt_H

Re: IDE CDROM questions for TF536 with A2000.
« Reply #37 on: October 16, 2021, 01:48:32 AM »
which pin is pin 7?  thanks for that link!  definitely good but i'm no good at reading diagrams at least in relation to how they read looking at the db9 is it:

1  2  3  4  5
  6  7  8  9

?
Yes, that matches the pinout shown in the manual.

Offline part12studios

Re: IDE CDROM questions for TF536 with A2000.
« Reply #38 on: October 16, 2021, 10:07:38 PM »
awesome yea made the most sense but maybe it could have been say:

1  3  5  7  9
  2  4  6  8

Thanks for confirming.  I'll be taking it apart soon.  My downstairs area has been a mess and recent family activities kept me from cleaning things for the A2000 to have a responsible work area..  but I'll open it up asap to get some readings.