Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Hollywood MAL AMIStore App Store A600 Memory

Recent Posts

Pages: [1] 2 3 ... 10
1
Amiga Hardware Issues and discussion / BBoAH Down?
« Last post by QuikSanz on October 17, 2021, 03:00:04 AM »
Is it only me or is this a new issue?

Chris
2
Amiga Hardware Issues and discussion / Re: GVP Spectrum defective - replacement advice?
« Last post by Matt_H on October 17, 2021, 02:24:11 AM »
I agree with others above that the problem was your Zorro II bus being maxxed out.

As for the 9-pin adapter cable, it's for passthrough if you want to run the Spectrum and native Amiga video on the same monitor and autoswitch between them. If you want to run Amiga native modes on a 1084 (or similar) and Spectrum modes on a VGA monitor you don't need the adapter.
3
I think that first thing you should do it test it only with 2630.
If you mean "don't enable the 2632" then yes, that's the plan.

Just out of curiosity, can I use the Spectrum without that 23 - 9 pin jumper cable?  It's not clear form the manual.  They talk about a "multi-monitor" setup but they seem to mean more than one Spectrum in the same machine, not a VGA monitor on the Spectrum and my NTSC CRT on the Amiga video port.
4
awesome yea made the most sense but maybe it could have been say:

1  3  5  7  9
  2  4  6  8

Thanks for confirming.  I'll be taking it apart soon.  My downstairs area has been a mess and recent family activities kept me from cleaning things for the A2000 to have a responsible work area..  but I'll open it up asap to get some readings. 
5
I think that first thing you should do it test it only with 2630.
6
IF you have a PC Bridgeboard, that would also require some 4mb free Zorro II memory space.
Anh, I should update my profile.   I do have a Bridgeboard but it is not currently installed.
I think that you have 4mb + 4mb + 4mb + 2mb, wich is way too much 100% sure would cause troubles.
Right now I *think* I have 4MB on the 2630 and 4MB on the GVP 2000.  The 2MB on the Spectrum is supposedly not Z-II RAM.  If I'm reading the showconfig right, the "(@$0 2meg)" there means 2MB starting at address 0.  Then there are three chunks of 64K from the Denise and x-surf at $EA0000, $EB0000, and $EC0000.  I'm going to solder up a connector and try installing the Spectrum software.  If that doesn't work, I'll remove the GVP 2000 RAM.
7
its live for a while now, join in!
8
Heads up, the ZZ9000 has 4MB mem in Zorro2 mode.

Chris
Thanks, that's good to know.  I guess I could just pull the 4MB out of the GVP 2000 in that case.
9
Heads up, the ZZ9000 has 4MB mem in Zorro2 mode.

Chris
10
Thanks.  I cleaned the card edge connectors but that didn't help.  I can't easily move it to a different slot because the only free slot I have left is the leftmost Zorro+PC Bridgeboard slot.  But I did put the Deneb in that slot and it was reported as working.

Then I looked at my old post https://forum.amiga.org/index.php?topic=62988.0 where I apparently had trouble with this board incident to 2632 issues nine years ago (completely forgot about that).  Apparently, the Spectrum has 2MB of RAM on it (4x 4C16257) and reported 2M in the showconfig I did in the previous post.

So that puts me over the Zorro II 8M limit* since I already have 4M on the GVP 2000 HC+8 and 4M on the A2630,  But would that be enough to cause the preboot diagnostics to report the Spectrum as defective?  It looks like it was working enough to show up in showconfig last time around.

The ZZ9000 looks like exactly what I want.  If I can't get the Spectrum to work, that may be the solution.  There is currently nothing at all on Ebay.  Do you have a pointer to a kit for this?  My search turned up nothing.

* Maybe. http://amiga.resource.cx/exp/impact2000hc8 says about the GVP 2000:
Quote
accepts SIMMs in groups of two, giving 2, 4, 6 or 8 MB configurations
this memory is technically not Zorro II memory - data is DMA-d from the HD as normal, but not via the Zorro bus for added speed
so then I'd only have 6 MB (4 on the 2630 and 2 on the Specturm).

UPDATE:
I thought maybe the expansion board diagnostics are confused so I tried booting the system with the Spectrum in it, and it worked:

Quote
1.FS3:> showconfig
PROCESSOR:      CPU 68030/68882fpu/68030mmu
CUSTOM CHIPS:   ECS NTSC Agnus (id=$0030), ECS Denise (id=$00FC)
VERS:   Kickstart version 40.63, Exec version 40.10, Disk version 45.3
RAM:    Node type $A, Attributes $605 (FAST), at $200000-$9FFFFF (8.0 meg)
        Node type $A, Attributes $703 (CHIP), at $400-$1FFFFF (~2.0 meg)
BOARDS:
 CBM A2630 68030/RAM card:   Prod=514/81($202/$51) (@$200000 4meg Mem)
 Board + ROM (HD?) (Great Valley Products):   Prod=2017/11($7E1/$B) (@$E90000 64K)
 RAM (Great Valley Products):   Prod=2017/10($7E1/$A) (@$600000 4meg Mem)
 Board (Individual Computers):   Prod=4626/23($1212/$17) (@$EA0000 64K)
 Board (unidentified):   Prod=3643/18($E3B/$12) (@$EB0000 64K)
 Board + ROM (HD?) (unidentified):   Prod=3643/19($E3B/$13) (@$EC0000 64K)
 Board (Viona Development):   Prod=2193/1($891/$1) (@$0 2meg)
1.FS3:>
So at least something is working.  Now I have to make a jumper cable to connect it to the Amiga's video out since I can't find the one that supposedly came with the Spectrum.
Pages: [1] 2 3 ... 10