Welcome, Guest. Please login or register.
Amiga Kit Amiga Store Iridium Banner AMIStore App Store A1200/A600 4xIDE Interface

Recent Posts

Pages: [1] 2 3 ... 10
1
General chat about Amiga topics / Re: AmigaOneXE High CPU
« Last post by nbache on May 20, 2022, 04:36:07 PM »
My XE G4 has been out of action for years now, but back when it worked, I did use a Radeon 9250 in the AGP slot with no obvious problems. My machine had not been "fixed", it was in the original state.

And I never heard that it should be a problem to use the AGP slot in that situation - but that doesn't necessarily mean it isn't :-).

IIRC, I used an SiI0680 and an SiI3114, and also the internal ports for CD and a boot HD (the internal ports of course in PIO mode).

Best regards,

Niels
2
General chat about Amiga topics / Re: AmigaOneXE High CPU
« Last post by cehofer on May 20, 2022, 02:22:51 PM »
Can somebody explain to me the AGP port on the XE?  I have had A1XEG4 since 2009.  I have done a lot of work on it to make it stable.  Maybe I should showcase my XE and explain all I have done to make it stable.  It has a few quirks but for the most part it is very stable.  The biggest pitfalls I found with it were memory and the harddrive.   I also will totally disagree that you can only use 1 memory stick for a total of 512Mb of ram.  I have had for years now 2 sticks running 2GB of RAM.  I actually found the memory issue using the serial port to a terminal on boot.  The next huge instability was the HD that came with the box.  It was an old Maxtore and I replaced it with a Seagate 316002 160GB Eide.  I actually have a SATA SIIG 3112 that I was going to swap to see what happens.  The other early on thing I did was shorten the teflon post on the CPU to make the module sit parallel to the MB.  When I got this machine it wouldn't boot at all but as soon as I removed the cpu and reseated it, it started working.

So back to the AGP port.  I was told early on NOT to use the AGP port and use only a PCI Graphics card.  I am currently using a Radeon 9200M 256MB.  I would also take any advice on how to optimize the Graphics to get the most out of this card.

Since I do not use any of the onboard devices except the NIC am I correct on assuming that DMA is not an issue and AGP should be fair game?  I think this would open me up to more modern and faster Radeon cards.  I saw an old post on another board where they said AGP was fair game if the DMA issue was fixed.   I can't tell you if the "fix" was applied to my board without removing it.
3
General chat about Amiga topics / Re: Lets talk about A1222 - Tabor
« Last post by jj on May 20, 2022, 12:56:50 PM »
Wrong thread :)
4
General chat about Amiga topics / Re: AmigaOneXE High CPU
« Last post by cehofer on May 19, 2022, 09:28:07 PM »
You are correct about uBoot.  It was there for the 0680 and others and PIO was selected as the prefered xfer.  I switched it to DMA.

Earlier, I had found in SysMon that I could add the following to the startup-sequence to do the same thing.

IDETOOL -X sii0680ide.device 0 69 >NIL:
IDETOOL -X sii0680ide.device 2 66 >NIL:

It WB boots super fast now.  It seems very stable too.  I will test more.

So this is what it put in my nvgetvar:
Mine would have worked but I put sii0680ide-xfer=F0C0 instead of sii0680ide_xfer=F0C0 :o

12.System:> nvgetvar
a1ide_xfer=0000
bootcmd=menu; run menuboot_cmd
bootdelay=0
baudrate=115200
preboot=
sii0680ide_maxbus=2
sii0680ide_xfer=F0C0/b]

stdout=vga
stdin=ps2kbd
ide_doreset=on
ide_cd_timeout=30
menucmd=menu
bootmethod=boota
ethact=3Com 3c920c#0
boot1=psii
boot_config=Default
boota_timeout=10
serial1_address=3f8
serial2_address=2f8
parallel_mode=0
parallel_address=378
usb0_enable=on
usb1_enable=off
usb_use_header=0
ide_maxbus=0
ide_swap=0
ethaddr=00:09:D2:11:03:70
ipaddr=<unset>
serverip=<unset>
boot_method=boota
menuboot_delay=3
os4_commandline=debuglevel=0
bootargs=root=/dev/ram rw ramdisk=4096
pci_irqa=9
pci_irqa_select=level
pci_irqb=10
pci_irqb_select=level
pci_irqc=11
pci_irqc_select=level
pci_irqd=7
pci_irqd_select=level
agp_enable=on
agp_sideband=off
agp_speed=2x
boot2=
boot3=
video_num=1
video_activate=pci
limit_memory=1024
use_memory_limit=no
12.System:>
5
General chat about Amiga topics / Re: Lets talk about A1222 - Tabor
« Last post by cehofer on May 19, 2022, 09:15:04 PM »
Following "SysMon" I was able to force it there so I added the following to my start-upsequence after Load Mondrvs

IDETOOL -X sii0680ide.device 0 69 >NIL:
IDETOOL -X sii0680ide.device 2 66 >NIL:

What a difference that made.  WB appears instantly now.  It seems stable too.  I will have to test more and research the help for siig0680ide.
6
General chat about Amiga topics / Re: AmigaOneXE High CPU
« Last post by lionstorm on May 19, 2022, 09:09:21 PM »
since you have an A1XE, you should have in prefs a dedicated UBoot preferences where you can set whatever you want without the hassle of typing in the UBoot prompt !
7
General chat about Amiga topics / Re: Lets talk about A1222 - Tabor
« Last post by psxphill on May 19, 2022, 05:25:41 PM »
For instance, many of the dependencies for projects like this one are in China - have you noticed recently how they are dealing with the pandemic?

They seem to have set a time table for coming out of lockdown, maybe they run out of bananas for making banana bread.
8
Amiga Software Issues and Discussion / Re: Aminet FTP
« Last post by zipper on May 19, 2022, 04:40:29 PM »
being able to connect to us3.aminet.net- I only get an empty directory no matter what I CD into… /pub/aminet, aminet, / etc etc
Try using simply aminet.net (without the us3 prefix), it should connect you to a working server. Best regards, Niels

Yes, I just tried with IE (most browsers don't support FTP anymore). ftp.aminet.net worked without problems.
9
Amiga Software Issues and Discussion / Re: Aminet FTP
« Last post by nbache on May 19, 2022, 04:25:55 PM »
being able to connect to us3.aminet.net- I only get an empty directory no matter what I CD into… /pub/aminet, aminet, / etc etc
Try using simply aminet.net (without the us3 prefix), it should connect you to a working server.

Best regards,

Niels
10
General chat about Amiga topics / Re: Lets talk about A1222 - Tabor
« Last post by nbache on May 19, 2022, 04:22:50 PM »
@cehofer:
Quote
Now the lockdowns are over
In all fairness, that depends very much on where in the world you are.

For instance, many of the dependencies for projects like this one are in China - have you noticed recently how they are dealing with the pandemic?

Best regards,

Niels
Pages: [1] 2 3 ... 10